• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Gamemaker 1.4 YYC and visual studio related stuff.

pixeltroid

Member
I tried compiling my project with the YYC compiler and got an error (I don't remember what it was but it had something to do with a missing SDK or something. I searched this forum and found a thread where someone else had the same problem and was advised to install visual studio 2013. I did so and ended up with confusing error messages.

So I ran another search on this forum and found a thread saying to install VS 2014 and that it has "all the required elements to make YYC work. "

The link in that thread sends me to a page where I can download VS 2019. My question is, will installing that version that resolve my issues? And what version of visual studio do you recommend?
 

rIKmAN

Member
I tried compiling my project with the YYC compiler and got an error (I don't remember what it was but it had something to do with a missing SDK or something. I searched this forum and found a thread where someone else had the same problem and was advised to install visual studio 2013. I did so and ended up with confusing error messages.

So I ran another search on this forum and found a thread saying to install VS 2014 and that it has "all the required elements to make YYC work. "

The link in that thread sends me to a page where I can download VS 2019. My question is, will installing that version that resolve my issues? And what version of visual studio do you recommend?
The Required SKDs article for YYC on 1.4 says to use VS2013, so if you were getting errors then it's proabably because you didn't install all the required tools etc during the install, something else that is required isn't installed or your preference settings are pointing to the wrong location.

I haven't used 1.4 in forever, but I don't remember ever having a problem using YYC with VS2013 - it would help if you could post the actual error message you get.
 

pixeltroid

Member
The Required SKDs article for YYC on 1.4 says to use VS2013, so if you were getting errors then it's proabably because you didn't install all the required tools etc during the install, something else that is required isn't installed or your preference settings are pointing to the wrong location.

I haven't used 1.4 in forever, but I don't remember ever having a problem using YYC with VS2013 - it would help if you could post the actual error message you get.
Hi. I installed VS2013 from links I found in this thread : https://forum.yoyogames.com/index.php?threads/yyc-and-windows-10.4023/#post-34230

Everything downloaded and installed without any issues. But when I tried to compile the project I received some unusual errors. I forgot to copy paste it somewhere for documentation.

But I just googled the matter and found this page from the yoyo games help website. It says Windows 7 or 8 users need Visual Studio 2012 Express for Windows Desktop. Also, in the thread I linked above you said that Visual Studio 2012 Express is required.

I found it and I'm just installing it right now. I'll report back on what happens.
 
This error seems to have different fixes based on what version of windows you're using, so what are you using?
The issue was all of a sudden, I tried running my game to playtest it one day on GMS 1.4, It quickly gave me an error that said "Windows SDK directory not found."

I ended up just exporting my project and deleting the Gamemaker studio data in my documents folder, reinstalling GMS 1.4 and the issue was gone.
 
Top