• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM Game wont run anymore?!


I tried to run the game and the console and everything booted (Compile works completely fine) but the game doesnt start?! why? Help!


Have you tried cleaning the build? (press the broom icon at the top)
Sometimes the same thing would happen for my games and cleaning the build usually fixes it


šŸ§ *penguin noises*
GMC Elder
Also, check that the game doesn't run into an infinite loop the moment it starts (if this happens before the first draw event, the window might not even pop up even though the game is running). Even finite loops can give this behavior if they're long enough (like looping over 10 million entries instead of 100 because you added too many zeroes somewhere without realizing). It's hard to tell if your game is in an infinite loop, but opening Task Manager to see if the runner executable is using lots of CPU power is a quick and easy way.