• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Game test not running.

Ivish

Member
I'm kind of new to GMS 2 and I'm working on my first game. I have 1 sprite, 1 object and 1 empty room. I placed the object in the room and tried to run it, but it refused. There aren't any compile or syntax errors, but the Output keeps talking about "cmd." My game just won't run. The last paragraph appearing in Output is:
elapsed time 00:00:00.0269950s for command "cmd" /c subst X: /d started at 07/22/2020 11:52:39
FAILED: Run Program Complete
For the details of why this build failed, please review the whole log above and also see your Compile Errors window.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Can you post the complete compiler log please? (Use [SPOILER] [/SPOILER] tags please).
 

Skripter

Member
Hey. I guess you use steam version as I do. If not, download steam-version and log-in into your YoYoGames-account. Before starting the application through steam:
  1. Go to your steam library
  2. Find GameMaker Studio 2
  3. Right-Click on title>Properties
  4. Select "Betas"
  5. Select newest beta-version
  6. 'Run' works now
Seems like current build on steam is bugged, also bought GMS2 today and couldn't use it... I became quite salty.

Edit: Beta-version may be instable but now it also stopped working there for me to run the game without any errors or time-retards - the execution
of the project is retarded and takes like 1 minute or smth now. There's definitely a bug behind as I'm using VM which doesn't require any setup-stuff like SDKs etc.
 
Last edited:
Top