Game Maker wastes disk space. Help.

PlayerX

Member
Hello, I am facing a rather annoying problem. Little space is allocated on my system disk, and the program wastes space with each launch, in particular 20 megabytes. The computer is not mine, I cannot afford to allocate more space. How can you fix this? Is there any file where all the launch records are located, or a function in the settings?
 

FrostyCat

Member
Solution 1: Make the IDE clear on close

Check the following:
  • General Settings > Paths > IDE > Automatically delete temp directory on close
  • General Settings > Paths > IDE > Automatically delete asset cache directory on close
  • General Settings > Paths > IDE > Automatically delete ide cache directory on close
Note: This will not work if the GMS 2 IDE closes due to a crash. If your GMS 2 IDE is on Windows and tends to be unstable, use solution 2.

Solution 2: Use the temporary directory (Windows-only)

Press Windows+R and run this:
Code:
explorer %temp%
Then copy the path in the address bar.
  • General Settings > Paths > IDE > Temp directory: <copied temp path>\GameMakerStudio2\Temp
  • General Settings > Paths > IDE > IDE cache directory: <copied temp path>\GameMakerStudio2\IDE
  • General Settings > Paths > IDE > Asset directory: <copied temp path>\GameMakerStudio2\Asset
Running Disk Cleanup regularly will also clear these directories.
 
Top