• Hey! Guest! The 40th (!!!) GMC Jam will take place between February 25th, 12:00 UTC to March 1st 12:00 UTC. Why not join in this very special anniversary jam! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ Game Maker Studio 2.3 so slow to compile on windows 10

Mehdi

Member
Hi everyone
I've recently switched to windows 10. Surprisingly when I compile my project it takes at least 30 seconds to compile and it's so frustrating.
It used to be only 10 seconds before (when i worked with windows 7) Can anyone help?
 

rIKmAN

Member
Antivirus software?
Windows Defender is installed by default with realtime protection turned on, so try turning it off and it it helps then add the relevent directories to the exclusion list / whitelist so they don't get monitored and scanned.

Also, have you installed all the latest manufacturers drivers for your hardware?
Windows 10 default drivers will be slower than proper manufacturers drivers (motherboard/chipset drivers etc).
 

Mehdi

Member
I've checked all these. The problem seems to exist somewhere else. Please pay attention to output:

ProjectFileWatcher:StartWatching:E:\Pumpkin\GMS2.3\new985
Started: 9/12/2020 8:45:50 PM
Finished: 9/12/2020 8:46:07 PM
Diff: 00:00:17.3400886

What is this file watcher? It seems that its taking 17 seconds apparently to watch the files.
I disable this feature in preferences but it is still there in output.
 
Last edited:

FoxyOfJungle

Kazan Games
As Windows 10 requires a little more hardware, it can probably be a factor, you can try to disable some services that will not serve you.
Try: Windows + R and type msconfig, go to the services tab and disable the desired ones, try to optimize your computer to the maximum. What is your configuration? Do you use SSD or HDD? 7200 RPM or 5900 RPM?
 

Mehdi

Member
As Windows 10 requires a little more hardware, it can probably be a factor, you can try to disable some services that will not serve you.
Try: Windows + R and type msconfig, go to the services tab and disable the desired ones, try to optimize your computer to the maximum. What is your configuration? Do you use SSD or HDD? 7200 RPM or 5900 RPM?
Hey Thanks for reply.
My hardware isnt that bad. Laptop core i7 , 8gb RAM. But it is HDD. Concerning RPM I dont know the answer.
By the way, the windows is fresh and I have not installed many programs so far. I think something newly added to GM 2.3 is causing the problem: File Watcher.

Capture.PNG

here as you can see, File Watcher has taken 18 seconds. It has an option to disable it in the preferences:

Capture2.PNG

But it has no effect. It still shows there in the output.:(
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
Disabling the file watcher really isn't recommended and will have no effect on the compilation times anyway. Disabling it just means that if you make any external changes to files then they will not be picked up by the IDE (eg: editing a sprite image on disk). It HAS to run when you compile though as it needs to check the files on disk to actually compile. ;)
 

TsukaYuriko

šŸŒ 
Forum Staff
Moderator
That's a setting related to your graphics card (FreeSync for AMD, G-Sync for Nvidia). You can find it in the respective GPU manufacturer's control panel.
 

Mehdi

Member
That's a setting related to your graphics card (FreeSync for AMD, G-Sync for Nvidia). You can find it in the respective GPU manufacturer's control panel.
Thank you. I searched everywhere. But my Nvidia Geforce 610m doesn't seem to have G-Sync at its control panel.:(
 

Attachments

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
I can't see this helping you, tbh... It's related to graphics and should not affect compiling in any way as that's a CPU thing not a GPU thing. Do you have a wireless keyboard? As mentioned above, there is a known issue with some Corsair wireless keyboards affecting the compile time. Also, try compiling without ANY anti-virus software running and see if that helps. You may need to whitelist GameMaker, as your virus scanner could be checking all the files each time you compile.
 

Mehdi

Member
I can't see this helping you, tbh... It's related to graphics and should not affect compiling in any way as that's a CPU thing not a GPU thing. Do you have a wireless keyboard? As mentioned above, there is a known issue with some Corsair wireless keyboards affecting the compile time. Also, try compiling without ANY anti-virus software running and see if that helps. You may need to whitelist GameMaker, as your virus scanner could be checking all the files each time you compile.
Thank you nocturne. In fact I disabled antivirus but still no effect. BTW i have a wireless mouse that I detached it. again no effect.
The main reason seems to be : Found Project Format 2. Because it waits a long time on this when compiling.
 
Hey Thanks for reply.
My hardware isnt that bad. Laptop core i7 , 8gb RAM. But it is HDD. Concerning RPM I dont know the answer.
By the way, the windows is fresh and I have not installed many programs so far. I think something newly added to GM 2.3 is causing the problem: File Watcher.

View attachment 34308

here as you can see, File Watcher has taken 18 seconds. It has an option to disable it in the preferences:

View attachment 34309

But it has no effect. It still shows there in the output.:(
I suspect the file watcher you see in the log is used to check which files in the project have been changed since the last run and thus need to be recompiled.
If that's the case, then the setting you disabled doesn't (and really shouldn't) affect it.

Anyway...

Is E: a virtual drive?
Is it pointing to an USB or network drive?
How may files do you have in the project?
What happens if you open a smaller project and try to compile it?
(hint: download and compile the Yoyo Dungeon demo an see what happens...)
 

Tyg

Member
I had this problem a few versions ago, are you using the latest gamemaker version because i dont have that prob anymore
It would compile slow, even small projects, when i checked the yyp project file it was huge way bigger than it should be
So i made a new project and added everything from the original project.
and the yyp was back to what it should be and compiled fast again
Not sure why it did this but i definately keep an eye on the yyp filesize if it compiles slow, it probably is trying to compile huge file
I think it was duplicating things in other folders, not sure why
 
Top