game maker studio 1.4 slow launch

Discussion in 'Legacy GameMaker Community Tech Support' started by Joh, Jan 6, 2019.

  1. Joh

    Joh Member

    Joined:
    Jul 23, 2016
    Posts:
    53
    Hi,

    I have game maker studio 1.4.1763 and it is getting extremely unusable.
    when I launch it it takes like 30+ minutes to boot. I haven't updated it in forever (don't want anything to break) but somehow it got worse and worse.
    The 30 min launch is recent, no idea what cause it.
    It also gets unresponsive a lot.
    Before (and its still here) there was "An error has occurred in the script on this page" every launch.
    after that "stop running this script" <a script on this page is causing your browser to run slowly. if it continues to run your pc might become unresponsive> prompt (thats also still here)

    its clear GMS is trying to load stuff on a webpage and failing at it, but that breaks the whole program somehow.

    When I do make it in the editor, it works fine, its just the launching that is completely broken. I assume it's due to some connection attempts? Anyway to stop that? I don't want to update, so I'm not sure what it tries to connect for.

    Thank you!
     
  2. IndianaBones

    IndianaBones Member

    Joined:
    Jul 5, 2016
    Posts:
    1,930
    If you think its the network, try disabling the network adapter and see if that makes a difference.

    What version of windows are you using?

    I would try checking your windows temp folders, GMS 1.4 as well as other programs can create a bunch of files you don't need. Remove anything from the temp folders that is older than a day or so. If you want to be a bit on the cautious side, just move them elsewhere or leave them in the Recycle Bin, don't permanently delete them until you are sure there are no side effects.

    If you have access to another computer, install GMS 1.4 on there and see if it starts quickly or not.

    I can't remember if you can install multiple versions of GMS 1.4 on the same computer, so I would try installing the last release of GMS 1.4.9999 on another computer, and try opening your projects using that version. If all is ok, then you can safely remove your old version of GMS 1.4 and use the newest version.

    I used to get that browser error when starting GMS 1.4, but it didn't cause such a large delay in loading the app for me.

    The lastest version of GMS 1.4 fixes that. It also removes the networking and direct marketplace access so you'll have to evaluate it for yourself if it suits your needs.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice