• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Game Maker Asset Compiler Error

I managed to fix the SDK issue, but now the asset compiler gives me the following error:
"GameMaker: Studio AssetCompiler has encountered a problem.
We are sorry for the inconvenience.
Unable to find the specified file "
The solutions I found recommended me to switch from Visual Studio 11.0 to Visual Studio 12.0, but I'm already using Visual Studio 2013 (which is supposed to be 12.0 but seems to have installed itself on the 11.0 directory for some reason).

EDIT: Tried Visual Studio 2015, didn't work either. I'm using Windows 8.1 SDK if it helps.

I have no idea of what to do so I need help.

Hello, I was trying to compile my game when Game Maker (I'm using the the latest version of Studio 1.4) started to ask me to check if the "SDK settings are OK". I tried to check the SDK, reinstall GMS, install a more recent version of Windows SDK and Visual Studio, but nothing worked.
Game Maker itself seems to not acknowledge that the "include" folder is there and refuses to find iwindows.h because of that. Could someone please help me?
 
Last edited:
Top