• Hey! Guest! The 40th (!!!) GMC Jam will take place between February 25th, 12:00 UTC to March 1st 12:00 UTC. Why not join in this very special anniversary jam! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Game lags on TV full screen, but nowhere else

blexc

Member
Hello,

I'm working on a physics-based game. When I have friends come over to playtest it, I set it up on my TV. I'll connect my laptop to the TV with an HDMI. Lately, it plays on average at 55 fps, when it's supposed to be 60. Occasionally, it will spike to 30fps, which is practically unplayable.

I was thinking it had to do with the application surface being stretched to a large multiplier. My game's resolution is 960x540, and the TV is 3840x2160 -- exactly four times my game's resolution...

Here's what I am doing at the start of the game. (RES_H is equal to 540).
Capture.PNG

I resize the surface to be 960x540, and when I full screen it, I simply do this:
Capture.PNG

What's going on here? I've been doing optimization tricks (Texture Grouping, using the profiler, minimizing number of game objects in a room) without much luck.

Related to this, I recall trying to play Undertale on the TV and that lagged on full screen as well. Does this mean it's a Game Maker-specific thing, or something the user needs to handle themselves?
 

Karlstens

Member
Some TV’s have lag in their default view mode, in that if you push A to jump, the game looks to react a quarter of a second after. I know my Samsung TV has a ”Game mode” setting which turns off a bunch of image processing so that the game image appears quicker, and it is absolutely noticeable.

As a side note, obviously if you’re drawing more pixels then this may slow down the game fps, however you shouldn’t mix up high latency with low fps, as they are different problems in their own right with different solutions.
 

blexc

Member
My issue is not input latency; I'm dropping frames. I print the fps during playtesting and on average I get 50-55 fps. In any case, I figured out how to set my TV to "Gaming Mode" as well, but that didn't fix anything.
 

renex

Member
I'm working on a physics-based game. When I have friends come over to playtest it, I set it up on my TV. I'll connect my laptop to the TV with an HDMI. Lately, it plays on average at 55 fps, when it's supposed to be 60. Occasionally, it will spike to 30fps, which is practically unplayable.

(...)

Related to this, I recall trying to play Undertale on the TV and that lagged on full screen as well. Does this mean it's a Game Maker-specific thing, or something the user needs to handle themselves?
i've had a friend have the exact same issues when playing zeroranger on an external tv through hdmi. it's a very specific problem, and he had luck with my patch:


add dbghelp.dll as an included file, and then put a copy in studio's program files folder. that should automatically apply it in testing and builds.

let me know if it works for you!
 

blexc

Member
i've had a friend have the exact same issues when playing zeroranger on an external tv through hdmi. it's a very specific problem, and he had luck with my patch:


add dbghelp.dll as an included file, and then put a copy in studio's program files folder. that should automatically apply it in testing and builds.

let me know if it works for you!
hm, i don't see a .dll file. do you mind explaining a bit more how to set this up?
 

blexc

Member
Holy crap, that worked! My game runs at 60fps with practically no issues.

While playtesting through my levels, I noticed one brief lag spike, but perhaps it's related to my project. Of course, this is much better than a consistent 55fps.

Thanks for the help.

Edit: I would like to mention as well that I am using GameMaker Studio 2.
 
Last edited:
Top