• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

iOS Game compiles on Mac, but not on iOS


Hi! I'm trying to compile a game for iOS but it's not working out. I've followed Yoyo articles about setting up and managed to compile my game for Mac (both VM and YYC), however, when trying to compile for iOS (or even cleaning cache), I get this exception:

Setting up core libraries.. DONE. Base app delegate: iPad_RunnerAppDelegate
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   in GMAssetCompiler.Output.LLVM_iOS.(String , String , List`1 , List`1 , GMAssets )
   in GMAssetCompiler.IFFSaver.(GMAssets , String , List`1 )
   in GMAssetCompiler.IFFSaver.(GMAssets , String )
   in GMAssetCompiler.Program.(GMAssets )
   in GMAssetCompiler.Program.Reentry(String[] _args)
   --- End of inner exception stack trace ---
   in System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   in System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   in System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   in Igor.Program.(String )
   in Igor.iOSBuilder.Run()
Igor complete.
To test if it was a problem with my configurations, I tried to compile a GMS2 Demo project and it worked out perfectly, even when replacing the configurations to be exactly equal of my own project. What could be the issue? I'm using a rented Mac Big Sur, with XCode 13 with a simulated device (iOS 15).