• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows fps drops on full screen, direct play & Windows 10

R

Ricardo73

Guest
Hello.
I use Game Maker since years ago, first GM8 and now GMS. I never experienced this problem before until I upgraded from Windows 7 to Windows 10.

The games run fine in a window, but on full screen there is a serious lag, with constant micro-stops every few seconds.

The first time this happened, I didn't know what to do, but then running an old GM8 game Windows displayed a message about installing Direct Play. I accepted it and the issue was fixed. Good.

Recently I updated my graphic card drivers (NVIDIA GeForce GTX 780) though GeForce Experience, and the problem with lag on full screen is back!

I checked in: "Control panel/ Programs and Features/ Turn windows features on or off/ Legacy Components/ Direct Play", and the box is ticked! So what can I do now? I tried to untick and tick again, but nothing changes.

Then I go to Microsoft website and I find this:
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

https://msdn.microsoft.com/en-us/library/windows/desktop/bb153243(v=vs.85).aspx

I can not believe that I am the only one experiencing this issue. Any ideas?

Cheers.
 
R

Ricardo73

Guest
This is funny (in a non funny way). The problem was magically fixed so I forgot about it... until today. New Windows update. Frame-rate issues again.

I am still don't know if this is related to W10, to Nvidia or to Direct Play, those are just hypothesis as I can not find any information in internet about this issue.

Nobody here experience the same problems? Should I just wait until is fixed by little leprechauns?
 

KriLL

Member
Hello.
I use Game Maker since years ago, first GM8 and now GMS. I never experienced this problem before until I upgraded from Windows 7 to Windows 10.

The games run fine in a window, but on full screen there is a serious lag, with constant micro-stops every few seconds.

The first time this happened, I didn't know what to do, but then running an old GM8 game Windows displayed a message about installing Direct Play. I accepted it and the issue was fixed. Good.

Recently I updated my graphic card drivers (NVIDIA GeForce GTX 780) though GeForce Experience, and the problem with lag on full screen is back!

I checked in: "Control panel/ Programs and Features/ Turn windows features on or off/ Legacy Components/ Direct Play", and the box is ticked! So what can I do now? I tried to untick and tick again, but nothing changes.

Then I go to Microsoft website and I find this:
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

https://msdn.microsoft.com/en-us/library/windows/desktop/bb153243(v=vs.85).aspx

I can not believe that I am the only one experiencing this issue. Any ideas?

Cheers.

Hi, I run my game no issues on Windows 10. I have an I7, 16GB of RAM and a Geforce 780 Ti with Nvidia drivers v368.81. I havent made any changes to the nvidia settings for GMS. I am running the full version of Game Maker Studio v1.4.1757 (latest stable). I can run my game using the windows YYC compiler (which does give performance improvements) at 1920x1080 @ 60fps with swf images and 8x AA.

If you upgraded from Gm8 to Studio did you uninstall and reinstall GMS? If not id try doing a fresh install of GMS. Also make sure you have the Visual Studio 2012 installed (version 11) for compiling your game.

You could try turning on the debugging options https://docs.yoyogames.com/source/dadiospice/001_advanced use/011_debugging.html to see if you can see why your frame rate is dropping. If you are using the physics engine make sure you dont have collisions being spammed which can bring the frame rate to a half after a while.
 
R

Ricardo73

Guest
Thank you for the answer, Krill, but it have nothing to do with the points you mentioned. It is neither a bad installation, nor a problem with a specific game, nor a low end PC.

This is an on and off issue, apparently it happens when I update Windows, graphic drivers or something, and it "fixes magically itself" after a while, I don't know how or why. This cycle has repeated about three times (works fine, issues only in full screen, fine again, issues again) and right now I am having issues again. I have to test my game on a window because it is unplayable on full screen. But this will happen with any other GMS game, e.g. Steam version of Undertale.

I am trying to be as specific as I can, but I hardly understand this issue, and I can not find any information online. It is like I am the only one experiencing this...

Update: Ok, the last two days have been really weird, this problem has been appearing and disappearing alternately. I have micro stops on full screen every two-three seconds, then I leave the computer to do something else, when I am back hours later it is fixed. The next day it is there again... I am wondering if this is related to leaving the PC on sleep mode... but I think this is too crazy, it can't be related, can it?
 
Last edited by a moderator:
Top