Question - IDE Fonts in GMS 2 not created properly [FIXED in 2.2.2]

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Pineapple Lake, Jan 20, 2019.

  1. Pineapple Lake

    Pineapple Lake Member

    Joined:
    Aug 25, 2016
    Posts:
    87
    Hi everyone,

    I'm trying to make the big leap from GMS 1.4 to 2, but I keep running into a problem with my fonts.
    For some reasing my fonts are rendered differently in GMS 2, making them look shaky and weird.
    The problem lies with rendering the font texture pages (not in-game).

    My font is Arial 8, no anti-aliasing.

    In GMS 1.4 the texture page is created like this:
    [​IMG]
    Looks nice and crisp right?

    Well, GMS 2 creates the font with the exact same settings like this:

    [​IMG]
    Looks all shaky and weird...


    I've heard this has something to do with a change in FreeType version, but as far as I know no solutions have been presented in other topics (except going back to an earlier GMS 2, which is a no-go for me)

    Does anyone have an easy solution for this problem?
    My solution could be to use the GMS 1.4 texture page to manually create a font from sprite in GMS 2, but that would involve a lot of work and code rewriting...
     
    MarceloP and LamePower448 like this.
  2. Pineapple Lake

    Pineapple Lake Member

    Joined:
    Aug 25, 2016
    Posts:
    87
    Thanks everyone! Seems this issue is fixed in the new beta 2.2.2

    Hit Options and under Hinting change from 'Normal' to 'Monochrome'
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice