Windows Fan speed on laptop high when running executable? [solved]

Mick

Member
Hi!

I'm just about to release a game on Steam and I am trying to figure out why the fan speed of my laptop goes crazy when running the game through the Steam client. If I run the game though the GameMaker Studio IDE the fan speed doesn't increase (even with the Steam client running and the Steam ingame overlay enabled).

Does anybody know what could be the cause of this problem?

Grateful for any insight!
 

Mick

Member
The fan is speeding up because the CPU temperature rises to above 80 degrees celsius. On battery this doesn't happen. Looks like the CPU throttling gets stuck at 100% when the executable version of the game is running. The game works full speed with the lowest power option with CPU throttling to the lowest position. Changing the sleep margin does not seem to change anything, weird. I just tried another game on Steam and the temperature rose to a hefty 85 degrees, so seems like there is an issue with my power scheme or something...
 

Mick

Member
I found the root of the problem. Avast Antivirus has a game mode that automatically kicks in when a game is detected running. I thought it would only disable virus checking for the game files etc. but it actually switches the power plan on my laptop to high performance mode. An antivirus program switching the power plan without my knowledge, wth! So my problem had nothing to do with Gamemaker, but if somebody else have the same problem then look into the Avast antivirus and disable the automatic switching to the high performance power plan.
 

Smiechu

Member
Yeah...
Don't run porn sites, don't use software from torrents, or strange sources, be careful with unknown e-mails... and you don't need any antivirus software...
 
Top