• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Legacy GM "failed writing textures out" issue

hijong park

Member
Yesterday, something strange happened and my computer suddenly shutdown while making my game. after rebooting I realized that my project files are damaged, and game maker : studio 1 on steam didn't run properly. (just displayed a small empty window when running.)

Fortunately I recently backed up the project that I could recover it quickly and the game maker worked fine after reinstalling it.



However, after reinstalling game maker : studio a strange thing randomly happens. sometimes the game maker says 'failed writing textures out, clear asset cache and try again' when compiling. If I ignore this and run the game, all sprites are not displayed in the game. (except 3D models, as I'm making a 3D model using gmmod models) This issue also happens in my other projects so It must be an issue of game maker : studio itself. How to fix this ?
 

TsukaYuriko

šŸŒ 
Forum Staff
Moderator
This issue also happens in my other projects so It must be an issue of game maker : studio itself. How to fix this ?
Can, doesn't have to. Are all of these projects on the drive that was involved in this sudden outage? There's always a chance it got damaged in the process.

When you reinstalled GMS, did you follow this guide? https://help.yoyogames.com/hc/en-us/articles/216753708-How-to-perform-a-fresh-install-of-GM-S-1-4
If not, try reinstalling as instructed.

If the issue persists, I'd suggest checking out the hardware side, as this problem started occurring after the outage from what I understood. Run a system file check via the sfc /scannow command and a disk check via chkdsk (you may have to specify the drive and some additional parameters for this one).
If possible, also try compiling projects from and to a different drive to see whether that exhibits the same symptoms.
 

hijong park

Member
Can, doesn't have to. Are all of these projects on the drive that was involved in this sudden outage? There's always a chance it got damaged in the process.

When you reinstalled GMS, did you follow this guide? https://help.yoyogames.com/hc/en-us/articles/216753708-How-to-perform-a-fresh-install-of-GM-S-1-4
If not, try reinstalling as instructed.

If the issue persists, I'd suggest checking out the hardware side, as this problem started occurring after the outage from what I understood. Run a system file check via the sfc /scannow command and a disk check via chkdsk (you may have to specify the drive and some additional parameters for this one).
If possible, also try compiling projects from and to a different drive to see whether that exhibits the same symptoms.
After just clearing the cache the issue is solved. but thanks for the advise.
 
Top