• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED Failed to load resources

Marko03970

Member
Hello guys.
I have a problem with game maker studio 2.3+, everything was working well, but when I use Search & Replace All (when I want to change variables in the project on multiple places), and when I run the game it compiles, but I can't see anything. There are no resources loaded.
I was searching for solutions to fix that, but the only solution is to delete the key from {project_name}.yyp, but when I open it with a text editor (I tried with notepad and visual studio code), I can't see any key. Only the names of resources and paths to it. So I really don't know how to fix this.
For every sprite I got these error in output:
"could not open file C:\Users\[name]\Desktop\[Folder1]\[Folder2]\[Folder3]\[projet_name_folder]\sprites\[sprite_name]\c9586c9b-87ea-4d01-a3fb-44ba31d2a207.png, using blank 16x16 replacement :

Failed to load image C:\Users\[name]\Desktop\[Folder1]\[Folder2]\[Folder3]\[project_name_folder]\sprites\[sprite_name]\5217bcb7-64e2-41d2-a8c4-1194e5719b79.png"
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator

Please see that post and see if that resolves the issue for now.
 

Marko03970

Member
@Nocturne I used and created 4 texture groups. One for fonts, one for tilesets, and 2 for sprites. I also disabled the file system sandbox and I also checked "generate minimaps" for all texture groups. Now it's working, but when I tried only with adding new texture maps it was not working. All in all, thanks for the advice, I followed it and did some other things I found on forums and it's working. Hope it will not spoil again.
 
Top