1. Hello Guest! It's with a heavy heart that we must announce the removal of the Legacy GMC Archive. If you wish to save anything from it, now's the time! Please see this topic for more information.
    Dismiss Notice

HTML5 Facebook Instant Games - player photo iOS

Discussion in 'GameMaker Studio 2 Community Tech Support' started by clee2005, Aug 29, 2019.

  1. clee2005

    clee2005 Member

    Joined:
    Jun 25, 2016
    Posts:
    218
    The FBInstantGames extension seems to have a problem (or I do) returning the Photo Url for the player. This function FBInstant.player.getPhoto() works in Android and Web as expected, but when running on an iOS device the function returns undefined. The other functions like FBInstant.player.getName() work in iOS it's just this photo for some reason. Anyone run into this?

    Thanks,
    Chris
     
  2. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    348
    We're investigating a couple of tickets overnight for Apple warning about UIWebView usage. On the Apple docs page for that API, I just spotted the "Important" message about accessing photos - https://developer.apple.com/documentation/uikit/uiwebview

    We'll look into this as part of reviewing UIWebView usage in general, but perhaps the above info will hep you fix your project sooner.
     
  3. clee2005

    clee2005 Member

    Joined:
    Jun 25, 2016
    Posts:
    218
    @Dan Ah nice! Thanks very much for that... I'll look into it.

    Edit : I read through it and realized that I'm working on a Facebook Instant Game HTML5 export... so there is no info.plist or any native iOS structures... right?
     
    Last edited: Aug 30, 2019
  4. Dan

    Dan YoYo Games Staff YYG Staff

    Joined:
    Apr 15, 2016
    Posts:
    348
    Yes, I did come to the same realisation. Whoops! ;)

    I did also speak to the dev of the extension, and apparently it is already in need of an update, so it might be something fixed in the newer SDK. Alternatively, that message from Apple might point to a system setting or browser preference needs to be enabled for this functionality to work - like I say, we're going to start investigating a couple of these issues here soon anyway.
     
  5. clee2005

    clee2005 Member

    Joined:
    Jun 25, 2016
    Posts:
    218
    @Dan ok I guess I'll file a ticket just to ensure that it gets addressed. Just wanted to be clear that the function that isn't working is supposed to just return the Photo URL ... not even an image. Thanks!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice