• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Experiencing slow down in the editor after a few hours.

Robsferic

Member
Hi! I am Rob, from Hungary but I live in Spain, I am new to this forum and I am a game designer.
I have been using Game Maker 1.4 since 2014 and I have bought a GM2 lifetime license last year!

So since the last update of GM2 I have been experiencing an issue with the editor. As I am working on a project the program just starts to slow down and everything starts to work slowly. If I save close GM2 and open it everything is up at full speed again. Everything else, Google Chrome, Aimp and the explorer on my PC are running fine but GM2 slows down.

I checked and my CPU is at 23%, I have 16gb of DDR4 ram, MSi GTX970OC, Core i7-5820K CPU.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Hello! Your system specs seem fine so this sounds like some memory leak within GMS itself. Have you tested with various projects or just your current one? Can you relate the issue to any specific part of the IDE? Like, if you never open the room editor then the program works fine? Does it happen if you open the program and do nothing (ie: just leave GM running in the background)?
 

Robsferic

Member
Hello! Your system specs seem fine so this sounds like some memory leak within GMS itself. Have you tested with various projects or just your current one? Can you relate the issue to any specific part of the IDE? Like, if you never open the room editor then the program works fine? Does it happen if you open the program and do nothing (ie: just leave GM running in the background)?
Hello there!
So today I have been working for few hours now, and it seems there is no slow down. I am working in another project. So it might just be the Nokia Jam, and it was really weird because I was working in such a small room, and limited objects and sprites. I will try to test leaving the Nokia project running while I do other stuff without the room editor lets see what happens. It actually crashed on me once so it might be a problem with mi set up.
I will edit this post in a couple of hours to see if it is still happening.
UPDATE:
So I opened the project and left it running for 2 hours without the room editor open and it seemed to run fine. I will create YYZ and upload it with a bug report regardless. Thank you for you time and help!
 
Last edited:

Nocturne

Friendly Tyrant
Forum Staff
Admin
Hello there!
So today I have been working for few hours now, and it seems there is no slow down. I am working in another project. So it might just be the Nokia Jam, and it was really weird because I was working in such a small room, and limited objects and sprites. I will try to test leaving the Nokia project running while I do other stuff without the room editor lets see what happens. It actually crashed on me once so it might be a problem with mi set up.
I will edit this post in a couple of hours to see if it is still happening.
Okay, thanks! I would STRONGLY suggest that if the issue happens again then file a bug and include the project that is causing the issue. Regardless of whether it's all projects or just one, it shouldn't happen and YYG should look into it (you can file a bug from the HELP menu in GMS2, and you can use the EXPORT option from the file menu to create a YYZ of the project which can be uploaded with the bug report).
 
Top