1. Hey! Guest! The 36th GMC Jam will take place between February 27th, 12:00 UTC - March 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

Android Error with Keystore

Discussion in 'GameMaker Studio 2 Community Tech Support' started by ZrOne, Jul 15, 2017.

  1. ZrOne

    ZrOne Guest

    Hi,

    I'm unable to generate a keystore file in GM2:Mobile

    I get an error:
    JDK not installed correctly at location entered in Android Platform Settings;

    I tried re-installing java jdk1.8.0_131 x64 but no bueno, also tried x32 bit as well. My settings point to "C:\Java\jdk1.8.0_131"
    I also tried to generate the keystore manually from the JRE folder but no go as well when I import and click Show Key Hash I get the same error.

    Has anyone seen this, or has any clues where should I start fixing this?

    Thanks :)
     
  2. Guest

    Guest Guest

    I can verify you're not crazy, but I can't help. I assume that GMS2 is telling you that the Java JDK location is "Found." (If not, obviously, fix that.) But two days ago, I had to nuke GMS2 and reinstall from scratch, losing my settings. When I re-entered my keystore information and hit "import" I got the same error as you, even though my JDK was "found" and I hadn't changed any of my SDKs/JDKs. I mashed import/show key hash/import, maybe canceled and went back in, and---it worked. Not reassuring, I know. I've got nothing.
     
  3. ZrOne

    ZrOne Guest

    Not sure what I did but it's working now.
     
  4. Guest

    Guest Guest

    So, same as for me. That's not great.
     
  5. ZrOne

    ZrOne Guest

    You have to delete your previous.APK.. Kind of a stupid issue.
     
  6. raymondwinge

    raymondwinge Guest

    I had the same problem. Then I tried to create an executable, and I had to generate a Keystore first. I clicked on the Generate button and suddenly the problem was gone.
     
  7. Guest

    Guest Guest

    I remember I hit generate, then it told me I was going to overwrite my existing key store, so I hit cancel.... but then it did work. I wonder if there's a bug buried somewhere in there.
     
  8. Bacon&Onions

    Bacon&Onions Member

    Joined:
    Aug 2, 2017
    Posts:
    43
    I'm currently having the same problem however I can't get it to work no matter what I try to do.
     
  9. Bacon&Onions

    Bacon&Onions Member

    Joined:
    Aug 2, 2017
    Posts:
    43
    I get an error:
    JDK not installed correctly at location entered in Android Platform Settings;

    I've installed Android Studio and tried linking to
    A:\Program Files\Android\Android Studio\jre

    I've installed JDK 8u131 (64bit) and tried linking to
    A:\Program Files\Java\jdk1.8.0_131
    A:\Program Files\Java\jre1.8.0_131

    I always get that error though when I hit generate keystore
     
  10. Ergin Celik

    Ergin Celik Guest

    Hi everybody ! I have the same error. I just bought GMs 2 :(

    I tried to uninstall all my Java JDKs/JREs, and install only JDK 1.8.0_131, but this dosn't resolved the problem.

    Then, I tried to build the .apk ....and it worked. I took 11 minutes (first build for android) and GMS2 created the application. I tested it on a mobile device :)

    Maybe this can help somebody.
     
  11. Bacon&Onions

    Bacon&Onions Member

    Joined:
    Aug 2, 2017
    Posts:
    43
    Reinstalling gamemaker fixed the problem for me.
     
  12. Lakko

    Lakko Member

    Joined:
    Jun 24, 2016
    Posts:
    48
    i have the same problem.
    I've installed JDK 8u144 (64bit) here C:\Program Files\Java\jdk1.8.0_144
    but don't work.Reinstalling JDK in C:\Java\jdk1.8.0_144 fixed the problem.
    Hope it can help someone
     
  13. Reginaldo garcia br

    Reginaldo garcia br Member

    Joined:
    Feb 4, 2020
    Posts:
    1
    I had the same problem and error message, and found that I can solve this problem by going to android-sdk and looking for the sdk's default jdk.
     

Share This Page