Dedicated Server made in GMS 1.4

T

Toto

Guest
I made a multiplayer game from two separate project files: a server and a client. When the server application is running on one PC, two players from PCs on other networks can connect to it and everything works fine. I want to have this server application running at all times on an actual server, such as Amazon's EC2 servers, so that the game have online matchmaking. How would I do this? From what I understand, the GMS 1.4 Linux export is for Ubuntu only, not for any server operating systems. Like I said, the server application runs on my PC, which is running Windows 7, not any server operating system. How can I run a GMS 1.4 "game" on a server hosting platform?
 

The-any-Key

Member
I have tested Amazon, digital ocean and papercloud. Both ubuntu and windows 7. I can't even get GM games to start on a VM with virtual GPU. I think you need a computer service with physical GPU. But those are costly.
 

Jabbers

Member
The-any-Key is correct. I once spoke to Mike in a group chat about a special export that would allow you to produce a headless version of your game so you could create a dedicated server. He seemed for it, but it never publicly materialised and I doubt it ever will.

Another point: in GameMaker 1.4 the built-in server functionality was a bit slow, and it worked best for slow-paced games. You couldn't reliably design an MMO or a multiplayer FPS using the built-in server capability, and I assume the same is true in GMS2. If you want to make a dedicated server, or a server for a game that is fast-paced or needs to support a large player count, then it really is best to design one in another language, and then create the client in GameMaker.
 

The-any-Key

Member
It is not limited to Ubuntu if you know all the right dependencies that need to be installed.
Care to share?

I use these when Ubuntu users run into problems running a GMS game:
Code:
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install openssh-client openssh-server libopenal1 libopenal1:i386 libncurses5-dev:i386 libbz2-1.0:i386 libstdc++6:i386 libxxf86vm1 libssl1.0.0:i386 libglu1:i386 libxrandr-dev libxrandr2:i386 zip unzip fakeroot -y
 

Samuel Venable

Time Killer
I don't know off hand, I'll have to ask the guy who said got it working. He's a GM user but I don't think he has a GMC account. I'll get back to you when I hear from him. I'll ask what distros he tried and all that.
 
Top