• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows debug stopped working, getting client disconnected

BoB3k

Member
Out of nowhere my debugger stopped working. Whenever I run it just freezes, but if you look at the output it is printing over and over:

341 code buffers added (17826)
Client(0) Disconnected: 127.0.0.1
Debugger disconnected
Client(-1) Connected: 127.0.0.1


Now, I don't need any help checking my own PC. Debugger has worked for years. As far as I know nothing has changed on my end. So, I'm just wondering if anyone else has had this and knows what it is.

I did just updated to the new IDE v2.3.2.556 and might have to downgrade to see if that fixes it.

Thanks for any help
 
Last edited:

rIKmAN

Member
That isn't the new IDE, the current IDE is 2.3.2

However, every time I've updated my IDE the first run in debug mode always pops up the Windows Firewall dialog and I have to allow the connection, so it may be that your firewall is blocking the connection if you haven't allowed it either via the popup or manually.
 

BoB3k

Member
That's a typo its 2.3.2, it just came out like last week. i will edit my post.

Re: fierwall. it's not the firewall. i've done many GMS2 updates and never had this problem.
 

BoB3k

Member
I went ahead and switched back to version 2.3.1.542, and have no issues. I guess I'll report this as a bug.


IDE v2.3.2.556 running runtime v2.3.0.401, debug freezes.
 

rIKmAN

Member
That's a typo its 2.3.2, it just came out like last week. i will edit my post
Ah no worries, wasn't sure if you were sticking to 2.2 for some reason and that was the last release of it.

As per my previous post though, did Windows Firewall pop up a dialog asking you to allow the connection the first time you ran in debug mode?

If not (or you didn't allow it for some reason) I'd look into your firewall rules and see what they are.

Previous versions that work have likely already got firewall entries so the fact they work doesn't rule out this being a possible cause of the latest version not working.

It might also be a bug specific to the Stable release (I'm using the last beta which is the same as "Stable" in all but name) but I've had no issues with debugger and had to allow the connection via Windows Firewall popup.

This has popped up for every new version I've ran going back years, so would be worth checking just to rule it out before you file a bug.
 
Top