Windows Compile time abnormally long; tried a few things but it didn't work. Any suggestions?

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Paulo Oliveira, Jan 12, 2020.

  1. Paulo Oliveira

    Paulo Oliveira Member

    Joined:
    Jan 12, 2020
    Posts:
    3
    Hey there people! I've been developing a game with four of my buddies (their first time making games) and we're having a blast! Problem is, as of yesterday one of these buddies has been having a few tech issues which are really putting him off.

    For some reason, his compile time inexplicably jumped from ~10 seconds to ~40 seconds. This obviously makes testing minor changes an extremely tedious and frustrating task.

    We've tried reinstalling gamemaker 2; moving it to an SSD; adding antivirus exceptions for the gamemaker 2 executable and deleting the asset cache through preferences.

    Our project is very small and lightweight, but just to be sure my friend even tried to create and compile a new empty project - that also took ~40 seconds.

    Lastly, my friend also noticed that when he reboots his computer he manages to compile the game in the normal ~10 seconds for some 3 or 4 times before it slows down to ~40 seconds again.

    He's using Windows 10, Gamemaker Studio 2, IDE v2.2.5.481, Runtime v2.2.5.378

    Does anyone have any ideas for us to try?
     
  2. TsukaYuriko

    TsukaYuriko Q&A Spawn Camper Forum Staff Moderator

    Joined:
    Apr 21, 2016
    Posts:
    1,840
    Since you tried moving "it" (I assume this refers to the previous sentence's GMS 2?) to an SSD, did you also move the project and cache folders to said SSD? The latter two should make a much bigger difference, given that these are what's being read and written at compile time rather than the IDE's components.

    If your project and/or cache reside on an HDD, is said HDD low on space or heavily fragmented? Both can contribute to slowdowns.

    Is some sort of realtime protection, such as an antivirus or firewall software, running which may be analyzing the compiled files as they are being written?
     
  3. Paulo Oliveira

    Paulo Oliveira Member

    Joined:
    Jan 12, 2020
    Posts:
    3
    Hey there! By cache, I'm assuming you mean the asset cache directory; and if so, yes, it is located on the SSD. We have completely disabled Windows Defender using the registry and Malwarebytes through its menu. Unfortunately, that didn't get us any change in compile time at all.
     
  4. SoVes

    SoVes Member

    Joined:
    May 17, 2017
    Posts:
    158
    might be the same issue that I have and a few others. If the computer is plugged into a corsair K55 keyboard, unplugging when compiling will fix the issue. The drivers for the keyboard interfere with the compiler for some reason
     
  5. Paulo Oliveira

    Paulo Oliveira Member

    Joined:
    Jan 12, 2020
    Posts:
    3
    A very odd problem! Unfortunately, I don't happen to have a Corsair keyboard. I'll google my keyboard model to see if it has any problems with the compiler.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice