• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Windows Can't Properly Deploy Gamemaker Studio 1.4 Game From Windows To Linux

zinsy23

Member
Hi,
I'm trying to deploy a game to Ubuntu (Linux) using Gamemaker Studio 1.4 in Windows and I'm missing some libraries. I'm using Windows 10 to deploy to Ubuntu Studio 20.04. I've installed the libraries listed on this website, except I'm using lib32ncurses6 instead of lib32ncurses5 and libssl1.1:i386 instead of libssl1.0.0:i386. I'm getting an error like "./GMStudio_runner: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory".

I found libcrypto.so.1.1 in /lib/x86_64-linux-gnu (for 64-bit) and /lib/i386-linux-gnu (for 32-bit) which is more updated than what Gamemaker Studio 1.4 wants to deal with. I tried creating symlinks using ln -s in each of the corresponding folders to libcrypto.so.1.0.0 to hopefully trick it to using the old version. I also did it in /usr/lib and /usr/lib64 and no luck. I then got the same error, but for libssl.so.1.0.0, so I did the same thing for that as well. I now get error "./GMStudio_runner: /lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./GMStudio_runner)". Same with libssl.

Any idea on what to do about getting Gamemaker Studio 1.4 to work with the modern libraries?
I should also mention that I manually updated Gamemaker Studio's version of PuTTY by copying the executables from my PuTTY installation to fix an error I was having earlier.

Thanks.
 
Top