Windows Can't package as zip anymore.

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Henkle, Sep 13, 2019.

  1. Henkle

    Henkle Member

    Joined:
    Jun 20, 2018
    Posts:
    5
    Hey.
    So as the title suggests, for some reason I can no longer package my game into a zip.
    Running it works fine, same for packaging as installer, but every time I try to package as zip it throws an exception and outputs a corrupt file. This happens both using VM and YYC

    Here's the exception that appears in the compile output:
    Code:
    Exception during processing ICSharpCode.SharpZipLib.Zip.ZipException: Entry size/stream size mismatch
       at ICSharpCode.SharpZipLib.Zip.ZipFile.AddEntry(ZipFile workFile, ZipUpdate update)
       at ICSharpCode.SharpZipLib.Zip.ZipFile.RunUpdates()
       at ICSharpCode.SharpZipLib.Zip.ZipFile.CommitUpdate()
       at ..(String , String , String )
    I've found several instances of this happening to other people, but nothing on how to fix it. So I hope someone out there has a solution, because I can't test multiplayer features with only one instance of the game running.
     
  2. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    4,453
    What version of GMS2 are you using?
    Have you tried uninstalling / reinstalling GMS2?
     
  3. Henkle

    Henkle Member

    Joined:
    Jun 20, 2018
    Posts:
    5
    I'm using the latest steam version of both the IDE and runtime (ide 2.2.3.436 & runtime 2.2.3.344)
    I tried reinstalling just using the steam uninstaller earlier, which didn't work.
    Completely reinstalling using that article didn't work either, it's still giving the same error.

    edit: I managed to "fix" it??
    It was only happening to one project, but changing the name of that project seems to have fixed it.
    Very strange, the name had no special characters in it or anything wrong with it (it was simply called "online"), and it worked perfectly fine before all this.

    Creating an entirely fresh project with the same name produces the same error, so I guess gamemaker just decided there's something wrong with that particular project name for some reason.

    Anyway, Thanks for taking the time to respond. If you know anything else about this error, Please post it here because it could save a lot of googling in the future. There's barely any information about it that I could find, just a few empty threads here on the forum.
     
    Last edited: Sep 13, 2019
  4. Nocturne

    Nocturne Friendly Tyrant Forum Staff Admin

    Joined:
    Apr 13, 2016
    Posts:
    6,871
    Please file a bug report and let YYG know about the issue.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice