• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

UWP Can't authorize test accounts or connect to sandbox..

So I recently purchased the UWP export, and I was super excited. I even bought an xbox one s to go with it. So, I make all of the accounts, pay the $19 fee, and I keep getting a message that I need to contact my account administrator. I have tried contacting Microsoft and XBox both in regards to this matter. I keep getting passed off because no one knows how to help. I'm hoping someone else has had this issue, and may know where to direct me. Please forgive me, if this is the place to post this.
 
I'm getting THIS error in GMS2, as well..


Unable to decode the returned string from dpdeploy:System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()
at dpdeploy.Program.HttpGetExpect200(String _uri)


Anyone got any advice?
 

rIKmAN

Member
I purchased the UWP export myself recently and other than an issue with a port number listed in the setup guide everything worked fine.

Did you follow the setup guides for both Windows and Xbox?
They work, so follow them and get things setup.

What is giving you a message to contact an Administrator?
GMS2? Windows? The Xbox?

What version of GMS2 are you using?
Both runtime and IDE versions.
 
I'm getting the error in the Partner Center, when I try to add a test user.
I did follow those instructions. What was the issue with the port number?

IDE: 2.2.4.464
RT: 2.2.4.372
 

rIKmAN

Member
That's nothing to do with GMS2, that's to do with your MS account by the sounds of it.

The issue I had with the port number was when adding a UWP device in the target section of the GMS2 IDE.
The guide states that you should put the IP followed by a port number of 50443, when in fact the port I had to use was the one given in Device Portal when you turn it on in Windows Developer Settings - this will be different for everyone and not the exact port stated in the guide.

Other than that everything worked fine.

If you are getting errors on the MS Portal related to your MS Dev account then there isn't much anyone on here can do and you'll have to take it up with MS Support.
 
Last edited:
Hey, if you're still having issues with this I figured out one way to work this through. Don't use the sandbox used in the Partner Center.

Instead, use the sandbox XDKS.1 on the X-Box one. This allowed me to sign into my X-Box One through the developer account (the normal X-Box sign in email ie yahoo, hotmail; and not the crazy whatever other one; yeah, you can sign in now as a dev...Horray!) and to begin to work with Visual Studio to work through an initial C# program (it was another avenue I researched that was supposed to be done before being able to get X-Box UWP to work properly because of debugging and releasing remote access of a Visual Studio 2017 program (2015 or 2017 but not 2019) may work through some bugs (by the way, local 64 debug and release had to happen first for me before remote); but I couldn't do it with the initial sandbox I was issued in the center because the same message would come up) So I switched it up!

This XDKS sandbox allowed me to see remote access work from Visual Studio to X-Box while putting in my X-Box IP address in a blank C# program in the debug section (I didn't see it in a blank C++ program fyi).
I got the blank app running on the X-Box One. From there I worked through the kinks. While I happened to initially get Windows version working on GMS 2. Today, I didn't; but the UWP X-Box version is now running (which was my goal for the Creators Program) It's an amazing feeling to see it come up on the X-Box One. I'm sure there's more to it, but I don't care too much right now.

I literally don't want you going through the same stuff for a year to come to where I am at this point (taking months off somewhat discouraged here and there).. and I know looking into contacting Microsoft would charge money for them to answer the question because I saw your article awhile back and almost thought I needed to myself but it's like a contract and money involved and looked into it myself (at least, that was the impression I got and darn near gave up again for another so many months because nobody could give a good enough answer to this question on any forum. So this is one way I found to skin this cat. Being able to sign in makes a difference.)

I dunno if I'll ever get actual use from the sandbox I was given, but the XDKS.1 sandbox I found while searching YouTube videos works for me because I can use it with my X Box account. I just got my game to load up. It's not even close to being ready, but I just wanted walls and colored blocks to pop up. (I got my menu, my walls, but not my blocks/characters and this is where I am at at this point...and that's fine)

There must be a reason to be able to use the issued sandbox, but for now I'm bypassing it for as long as I can because it has been a stressful process to get to this point. So I'm happy to tell you this at 2AM. This is a step in a direction where light can be seen at the end of the tunnel. Good luck with your project BestGame! Have a Happy Holiday!

Old School
 
Last edited:
I actually was unable to get any kind of help from ANYONE, other than being sent the same 4/5 links repeatedly.. I got YoYo to swap me out for the HTML5 export, instead. Unfortunately, I had to take a significant financial loss to swap the products, but it kept me from dropping the IDE, altogether.. I was very close to switching to Unity, but didn't want to walk away from the $800 I had just spent on this software.. I'm glad I didn't. YoYo did their best to make me happy, but Microsoft, man....... I'll eventually pay to port to Switch and PSN, but I'll never put anything on XBox after that experience.
 
Top