Windows Cannot run game, please help!!!

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Metro Cinematic, Jun 16, 2019.

  1. Metro Cinematic

    Metro Cinematic Member

    Joined:
    Jun 16, 2019
    Posts:
    5
    IDE v2.2.2.413; Runtime v2.2.2.236

    Whenever I test run a project file on GMS 2, I am returned with the error "Unable to find game!!: Project.win". I have tried reinstalling GMS 2 and the runtimes, and I always run GMS 2 as an adminstrator.

    I've also tried:

    - Deleting the temp folder
    - Ensuring that all folders were in the same hard drive

    Intel Core i7 6500-U @ 2.5GHz
    GeForce 940M 2GB
    16GB RAM

    pls help me

    Log:
    Code:
    [00:55:36:365(17a9)] starting cmd /c subst Z: /d
    [00:55:36:618(17a9)] elapsed time 00:00:00.2533229s for command "cmd" /c subst Z: /d started at 06/16/2019 00:55:36
    [00:55:36:625(17a9)] IDE: SaveProjectIncremental()
    [00:55:36:625(17a9)] Setting FolderWatcher 'C:\Users\samim\Documents\GameMakerStudio2\BROJECT' to False
    [00:55:36:625(17a9)] Saving project to: C:\Users\samim\Documents\GameMakerStudio2\BROJECT\BROJECT.yyp
    [00:55:36:626(17a9)] Saving project at 'C:\Users\samim\Documents\GameMakerStudio2\BROJECT\BROJECT.yyp'
    [00:55:36:626(17a9)] Save project took 00:00:00
    [00:55:36:627(17a9)] Setting FolderWatcher 'C:\Users\samim\Documents\GameMakerStudio2\BROJECT' to True
    [00:55:36:680(17a9)] starting C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.2.326/bin/Igor.exe -j=8 -options="C:\temp\GMS2TEMP\build.bff"  -- Windows Run
    [00:55:40:14(17a9)] Suspend: Suspended = 1 for watcher 'C:\Users\samim\Documents\GameMakerStudio2\BROJECT'
    [00:55:44:141(17a9)] elapsed time 00:00:07.4619225s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.2.2.326/bin/Igor.exe" -j=8 -options="C:\temp\GMS2TEMP\build.bff"  -- Windows Run started at 06/16/2019 00:55:36
    [00:55:44:181(17a9)] starting cmd /c subst C: /d
    [00:55:44:484(17a9)] elapsed time 00:00:00.3026989s for command "cmd" /c subst C: /d started at 06/16/2019 00:55:44
    [00:55:44:490(17a9)] starting cmd /c subst C: /d
    [00:55:44:996(17a9)] elapsed time 00:00:00.5041936s for command "cmd" /c subst C: /d started at 06/16/2019 00:55:44
    [00:55:45:8(17a9)] starting cmd /c subst C: /d
    [00:55:45:413(17a9)] elapsed time 00:00:00.4064270s for command "cmd" /c subst C: /d started at 06/16/2019 00:55:45
     
    Last edited: Jun 16, 2019
  2. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    221
    Can you post the entire log output?
     
  3. Metro Cinematic

    Metro Cinematic Member

    Joined:
    Jun 16, 2019
    Posts:
    5
    I just did, check the edit
     
  4. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    221
    It doesn't show any errors there like you mentioned. Where is the message "Unable to find game!!: Project.win".? Where when you try to compile does it show it? Is this the entire log output?
     
    Last edited: Jun 16, 2019
    rIKmAN likes this.
  5. Metro Cinematic

    Metro Cinematic Member

    Joined:
    Jun 16, 2019
    Posts:
    5
    It wasn't the entire log file, but it was the last bit of it which I presumed would contain the error. However this is what I would get.
    upload_2019-6-16_1-18-3.png
    I'm unable to paste the full code onto here, but the log file is here:
    Code:
    https://www.filehosting.org/file/details/806398/ui.log
     
  6. Metro Cinematic

    Metro Cinematic Member

    Joined:
    Jun 16, 2019
    Posts:
    5
    As I await moderator approval for the last reply, I have discovered that the generated temp folders for the project on every test run is always empty, while a friend of mine tried testing his game file and it would generate a .win file every time (hence work). Any idea what this might be?
     
  7. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    221
    rIKmAN likes this.
  8. Metro Cinematic

    Metro Cinematic Member

    Joined:
    Jun 16, 2019
    Posts:
    5
    So thanks to that read, I figured out that my command prompt in general just doesn't open properly, and having made a new local account on my computer which ended up working, I was able to run command prompt just fine. Determining that the admin account was corrupted, I did a system reset. Now the game runs perfectly fine. Thanks a lot for your help friend :)
     
    Amon likes this.
  9. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    221
    You're welcome.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice