• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

can it run

TsukaYuriko

šŸŒ 
Forum Staff
Moderator
You can find the system requirements here and see for yourself: https://docs.yoyogames.com/source/dadiospice/000_using gamemaker/001_installation.html

Edit: 1.x, whoosp.
2.x requirements can be found on the Get page.
Windows
Minimum Spec

  • 64bit Intel compatible Dual Core CPU
  • 2GB RAM
  • DX11 compliant graphics card
  • Microsoft Windows 7 (64bit only, Service Pack 1 or above)
  • HDD with at least 3GB free disk space
  • Internet Connection
Recommended Spec

  • 64bit Intel compatible Quad Core CPU
  • 8GB RAM
  • DX11 based graphics card
  • Microsoft Windows 10 (64bit only)
  • SSD with at least 3GB free disk space
  • Internet Connection
 
Last edited:

rIKmAN

Member
Those are the requirements for GMS 1.4.

@Dis dude
The GMS2 Requirements can be found here - click "Windows" to open the dropdown.
For the Windows platform you will need to have the following basic setup:
  • 64bit Intel compatible Dual Core CPU
  • 2GB RAM
  • DX11 compliant graphics card
  • Microsoft 64bit Windows 7
  • At least 3GB free Hard Disk space
However the recommended specifications are:
  • 64bit Intel compatible Quad core CPU
  • 8GB RAM
  • DX11 based graphics card
  • Microsoft 64bit Windows 10
  • SSD Hard Disk
 
D

Dis dude

Guest
Do game maker studio and Game maker studio 2 have the same requirements
 

FrostyCat

Member
Do game maker studio and Game maker studio 2 have the same requirements
No, but your proposed setup is more than good enough to run both. I manage both with less.

On the community level, the difference hasn't made much of a dent. The only two items that even remotely did were these:
  • GMS 2.x strictly requires a 64-bit system, while GMS 1.4 can run on both 32-bit and 64-bit systems
  • GMS 2.x runs on DirectX 11, while GMS 1.4 runs on DirectX 9
These ran a few older systems from users in South America and the Near East out of town, but time moves on.
 
Last edited:
Top