BlackWindow

Faniquito

Member
Hello guys, I just downloaded GM and went to do the platform tutorial, but when I press play, the screen goes black, I don't know what to do




tenso.png
blackwindow.png
 

TheouAegis

Member
Make sure all windows are closed. You have the room editor open in that screenshot. Try closing the room editor.

If it's still black, go into oPlayer and in the Step Event put:

show_message("You can close the program now.")

Close the oPlayer editor, then try to run the game again. If you see don't see the text telling you to close the program, then you have an infinite loop in your Create event, Game Start event, Room Start event, or Draw event.

Also, make sure Visible is checked inside your objects. If they're not visible, they won't draw. And if nothing is drawing, you'll have a blank window.
 

Faniquito

Member
Make sure all windows are closed. You have the room editor open in that screenshot. Try closing the room editor.

If it's still black, go into oPlayer and in the Step Event put:

show_message("You can close the program now.")

Close the oPlayer editor, then try to run the game again. If you see don't see the text telling you to close the program, then you have an infinite loop in your Create event, Game Start event, Room Start event, or Draw event.

Also, make sure Visible is checked inside your objects. If they're not visible, they won't draw. And if nothing is drawing, you'll have a blank window.
Hello friend, thanks for answering me, I did everything you told me, the message really appeared but I still have the black screen
 

TheouAegis

Member
Try closing Game Maker and then reopening it. (GMS2.3 has a lot of issues like this for one reason or another. I have my ideas why.)

If that still doesn't work, move your sprites from the Sprites folder up to the Scripts folder. Save your game then test it again. If it works, you may be able to move the sprites back to the Sprites folder after moving them out. And if that ends up being what fixes it, then we narrowed down the issue to GM2.3's asset manager.
 

Faniquito

Member
Try closing Game Maker and then reopening it. (GMS2.3 has a lot of issues like this for one reason or another. I have my ideas why.)

If that still doesn't work, move your sprites from the Sprites folder up to the Scripts folder. Save your game then test it again. If it works, you may be able to move the sprites back to the Sprites folder after moving them out. And if that ends up being what fixes it, then we narrowed down the issue to GM2.3's asset manager.
I don't know if it's my computer or this version has a bug, I think I'll have to find another older version to use: '( because not work again haha oh god :'(
 
Top