• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

GMS 2.3+ Black screen problem

Hello this is my firts post, i notice a problem when i try to run the game because there was only a black screen, i am using the last GMS2 version, i was thinking it was a mistake i made but, i import a game maker example and try to run it, and there it was the black screen, at firts i thought it was my antivirus blocking igor.exe but it wasnt the case, help i really want to use GMS2
 

Tyg

Member
when you make a new game in gamemaker it creates a room with no instances
if you have imported an example i would think it came with a room
if thats the case it would run the rooms in order, being the blank room so the example room never would run
you can do 2 things delete the default room or switch the room order in the assets so the example room is first
if there was only 1 room, the example room then theres some problem
 

Tyg

Member
Not sure how your drawing it but there should be a icon that shows the picture in the room editor
from looking at your srceenshot it looks like your sprites folder is empty,
so your object doesnt have a sprite attached
where are you getting this square from?
 
I am having the same problem. I'm following this tutorial:

I tried Repairing Avast as well as disabling all security options, did not fix the issue. EDIT: I uninstalled Avast altogether and restarted my computer. Still have the same issue of blank sprites.

My Room:
2021-02-24_14h42_26.png

Objects to show they are marked visible:
2021-02-24_14h43_47.png
 
Last edited:

gnysek

Member
Did you checked this topic ?


Edit: I see that some of you already checked it. Can you close ALL other apps in background, to maybe detect what other tool is causing this? Don't forget to clear asset cache (broom icon on top) every time after something is disabled.
 

thehay95

Member
Did you checked this topic ?


Edit: I see that some of you already checked it. Can you close ALL other apps in background, to maybe detect what other tool is causing this? Don't forget to clear asset cache (broom icon on top) every time after something is disabled.
thank you so much, i fixed
 
Top