• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED Black screen on fullscreen/window mode change

bogo

Member
Hello, good people 👋
I've been working on my project without any problems for some time now and had some stuff done. Among other things, I had working window mode switching, but since a few days ago it all went south :eek: Most of the time when i'm switching fullscreen -> windowed or the other way around the screen goes black and I can't do anything: ctrl-alt-delete not working, win+l (logout), ctr-shift-esc, nothing, only hard restart helps. I've reinstalled graphic card drivers as well as GMS but the problem still persists. I tried to trace it by force quitting game, but sometimes it hangs right after window_set_fullscreen call, sometimes few lines of code later. I'm outta options and ideas :bash: Please help.

[EDIT] I've set up a completely new project, created an object where on space key press I negate fullscreen flag (fullscreen = !fullscreen) and then I call window_set_fullscreen(fullscreen) and game goes black screen when switching from fullscreen to window. ⬛

[EDIT] The same happens on latest BETA version of GMS2.
 
Last edited:

TsukaYuriko

☄️
Forum Staff
Moderator
Have you performed any hardware or software changes (e.g. Windows updates, driver updates, installed programs) around the time this issue started appearing?

Does the keyboard shortcut Shift+Ctrl+Win+B (restarts the GPU driver) do anything after this issue appears?

Does the Windows-internal Event Viewer (Win+R -> eventvwr) provide any information about what's happening?
 

bogo

Member
I performed windows update recently. After that I've installed latest video drivers. None of the shortcuts are working.
 

bogo

Member
This I cannot do - due to pandemic my home PC is also my work station and I need it to be stable. Is there any chance the issue will be recognised and handled in future versions of GMS maybe? Even if reverting update would help, the updates need to be carried out at some point anyway. There is a possibility that the cause is on Microsoft's end, but switching display modes for various games or GameMaker games works correctly.
 

TsukaYuriko

☄️
Forum Staff
Moderator
My suggestion was not for the purpose of resolving the issue, but tracking down the cause. ;) You are absolutely correct that reverting the update isn't a long-term solution, but in order to develop a proper fix, the root cause of the issue would first have to be identified - at which point it may not even be up to YoYo Games to fix, as it may be an issue on Microsoft's, Nvidia's or (insert the name of your favorite company to blame when stuff goes wrong here)'s end.

Either way, feel free to file a bug report so that tech support can take a look at it and so that the issue can be tracked. If this does turn out to be a GM-sided issue, a fix can then be considered for a future version.
 

bogo

Member
I would revert it, really, but the risk of my setup going to hell and loosing few days for configuration (I'm in software development) is too big. I've reported the bug and will hope it will get fixed one way or another and one day it will be just gone :) Thank you for the response.
 

Toulhane

Member
Hi, I have the exact same problem, I got a random blackscreen when I toggle fullscreen and I can't do anything except hard reset my pc. I'm on Game Maker 2.3.0.529 but the same happened with the previous version. tell me if you ever find a solution :)
 
Hi, I have also experienced this problem today, I've set up my fullscreen toggle to CTRL+F and when going from fullscreen to window, my computer goes to a blackscreen freeze and then only a hard restart works. The thing is that yesterday everything was working fine, and I had no windows updates scheduled nor I did any software update such as video drivers.

Also, checking the Game Option of allowing fullscreen switch, which enables the ALT+Enter toggle works perfectly fine, so I don't know why setting up my own toggle shortcut produces this error.

I'm currently using 2.3.0.529 creator version on Windows 10.
 

Gizmo199

Member
I had the problem a couple of years ago and just gave up on using the window_set_fullscreen command. I've found it doesnt mess up if (in game options) you turn the borderless window option on and just resize the window to the display dimensions using window_set_size().
 

YELLOW

Member
My suggestion was not for the purpose of resolving the issue, but tracking down the cause. ;) You are absolutely correct that reverting the update isn't a long-term solution, but in order to develop a proper fix, the root cause of the issue would first have to be identified - at which point it may not even be up to YoYo Games to fix, as it may be an issue on Microsoft's, Nvidia's or (insert the name of your favorite company to blame when stuff goes wrong here)'s end.

Either way, feel free to file a bug report so that tech support can take a look at it and so that the issue can be tracked. If this does turn out to be a GM-sided issue, a fix can then be considered for a future version.
I also encountered this problem: when switching full screen, the screen will be black, any input will fail, but you can hear the sound playing.

After my preliminary test, windows 10 virtual machine on VMware will not have this problem for the time being, so I began to doubt my graphics card.
-----------------
My device:
Windows 10 professional 2004
NVIDIA GeForce GTX 1050 27.21.14.5206
Gamemaker Studio2 Latest version
 

Svaisah

Member
Hey guys!

I've been dealing with this problem since yesterday. Today, I've found a solution that seems to work.

Go to the Game Maker Studio shortcut (or .exe) and right-click on "Properties". After that, go to the "Compatibility" tab. Finally, check "Open as Administrator" and "Disable fullscreen optimizations" or similar (sorry, my system is in Spanish and I'm not sure how it is in English).

That has made the error go away for me as it seems to be some kind of compatibility issue between Game Maker and Windows 10.

I'm using Game Maker Studio 2 v2.3.0.529.

Hope it helps!
 

YELLOW

Member
Hey guys!

I've been dealing with this problem since yesterday. Today, I've found a solution that seems to work.

Go to the Game Maker Studio shortcut (or .exe) and right-click on "Properties". After that, go to the "Compatibility" tab. Finally, check "Open as Administrator" and "Disable fullscreen optimizations" or similar (sorry, my system is in Spanish and I'm not sure how it is in English).

That has made the error go away for me as it seems to be some kind of compatibility issue between Game Maker and Windows 10.

I'm using Game Maker Studio 2 v2.3.0.529.

Hope it helps!
I have found all these options. My system language is simplified Chinese, and I believe that English language will also find it. It's just that I haven't tested it yet. I'll try it tonight. Anyway, thanks.
 
Hey guys!

I've been dealing with this problem since yesterday. Today, I've found a solution that seems to work.

Go to the Game Maker Studio shortcut (or .exe) and right-click on "Properties". After that, go to the "Compatibility" tab. Finally, check "Open as Administrator" and "Disable fullscreen optimizations" or similar (sorry, my system is in Spanish and I'm not sure how it is in English).

That has made the error go away for me as it seems to be some kind of compatibility issue between Game Maker and Windows 10.

I'm using Game Maker Studio 2 v2.3.0.529.

Hope it helps!
I just tried this and it worked for me, thank you so much mate, this thing was bothering me quite a lot.
 

bogo

Member
Hey guys!

I've been dealing with this problem since yesterday. Today, I've found a solution that seems to work.

Go to the Game Maker Studio shortcut (or .exe) and right-click on "Properties". After that, go to the "Compatibility" tab. Finally, check "Open as Administrator" and "Disable fullscreen optimizations" or similar (sorry, my system is in Spanish and I'm not sure how it is in English).

That has made the error go away for me as it seems to be some kind of compatibility issue between Game Maker and Windows 10.

I'm using Game Maker Studio 2 v2.3.0.529.

Hope it helps!
Yup, that helped. You deserve a medal, thank you! Still, a problem exists and I hope YoYo will fix it - you never know how the game will behave on end-user platforms and telling your players to set some options in .exe is not welcomed for sure.
 
Last edited:
I have the same problem. Disabling fullscreen optimizations stops the crashing/freezing, but now I get a black screen for 3-4 seconds inbetween switching to and from fullscreen.
 

Flaick

Member
Same issue here and solved with Svaisah suggestion. Thanks!
But this happen only when using GameMaker? Or maybe the .exe will be affected?
 

Samuel Venable

Time Killer
GameMaker uses what yoyo calls "true" fullscreen (which I'd rather call it "dumb" fullscreen because you can't use dialogs or embed controls with it) and for reasons like this :)

@YellowAfterlife fixed this when he merged my pull request to his "Window Freeze Fix" extension on itch.io, which now includes the window_set_fakefullscreen(full) function. Although it uses real fullscreen, I called it "fake" to poke fun at what YoYo considers "true" fullscreen.

Included with my video player extension available here for free: https://samuel-venable.itch.io/gamemaker-extension-collection (not to be confused with Video Player Pro, which is $9.99 but the exact same thing built for 64-bit as the only difference). I don't know if YAL happened to have updated the actual extension with this new feature exposed yet, but you can get it from my video player along with a usage example.
 

bogo

Member
hi guys,
I've been informed by YoYo team that the issue has been resolved with some remarks: "this version introduced a delay when calling window_set_fullscreen() in order to stop this stability issue, so if your game has code where you're changing the window size and immediately querying for the updated values, this won't work. You will need to always leave a 10-frame delay before querying the new window dimensions after calling window_set_fullscreen()." I tried it without temporary fixes provided by Svaisah and I can confirm this is fixed, so I am changing this thread to SOLVED.
 
Top