GMS 2 BGM Gets Lowered Even at Highest Priority

I have my game's BGM set to the highest priority over all other sounds. audio_play_sound(BGM_to_play, 1, true). But when other sounds start playing, like enemy bullet sounds, which are audio_play_sound(a_enemy_laser, 10, false) the BGM seems to get drowned out and lowered by all the other sounds even though the a_enemy_laser is set to a 10 priority.

How can I keep other sounds from lowering the BGM of the level? I even have the a_enemy_laser and other sounds at a lower volume than the BGM which is set at the highest volume.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
The manual isn't clear on this (and has been updated for the next release) but priority is actually incremental, so a higher value means a higher priority. So, your laser has a higher priority over your music at the moment. Note too, that your PC may be limiting the audio using some kind of compression algorithm (which is actually what this sounds like, as low priority sounds don't lower in volume, they stop altogether).
 
The manual isn't clear on this (and has been updated for the next release) but priority is actually incremental, so a higher value means a higher priority. So, your laser has a higher priority over your music at the moment. Note too, that your PC may be limiting the audio using some kind of compression algorithm (which is actually what this sounds like, as low priority sounds don't lower in volume, they stop altogether).
I just changed the BGM priority to 10 and the enemy laser sound to 1 and it seems I'm still getting the same issue. Plus, this is something that I've only noticed in GameMaker Studio 2. Other games don't seem to have this effect.

From searching online, this post on Reddit is the exact problem I'm having: reddit.com/r/gamemaker/comments/eqgl24/gms2_audio_issue_sounds_reduce_the_volume_of
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
As far as I know, GM doesn't do any audio compression on the output, and this must be a setting on your PC. Most sound drivers have options for limiting/compressing/equalizing audio, and the effect you describe (and is described in that reddit thread) sound more like that than an issue with GMS2. That said, feel free to file a bug with YYG and get an official response... I could be wrong, although it isn't something I've ever noticed myself in my own games.
 
As far as I know, GM doesn't do any audio compression on the output, and this must be a setting on your PC. Most sound drivers have options for limiting/compressing/equalizing audio, and the effect you describe (and is described in that reddit thread) sound more like that than an issue with GMS2. That said, feel free to file a bug with YYG and get an official response... I could be wrong, although it isn't something I've ever noticed myself in my own games.
Just wanted to update on the issue.

I turned off some audio settings/enhancements on my laptop and the prioritizing of audio seems to have stopped. But now sounds are muffled sounding. Since it's looking to be a PC settings issue, the way the music sounds could be different for each player. So, I'm not going to be too concerned about it.
 
Top