GMS 2 Background Resolution Lowered Ingame

Raptor_Guy

Member
When I play my game, the background resolution is lowered from what it is in the room editor. The background is the same size as the room.
Here's a screenshot of my background resolution in the room editor:
room.png

And here's the same room ingame:
ingame.png
 

rIKmAN

Member
If that background is the same size as your room (2000x8000) then it's way too big to fit on the texture page size that is selected by default, which means it will get halved by GMS repeatedly until it does fit.

Change your texture page size in Resource Tree > Options > Windows > Graphics.

However that image is much too big and you should resize it - the most common full screen resolution is 1920x1080, so for a single screen background you can see that 2000x8000 is much too big and a waste of resources.
 

Raptor_Guy

Member
Thanks for the replies. My game is vertical, so would there be a way to tile a blue background above the initial sun/mountain part?
 

Raptor_Guy

Member
After messing around for a bit, I solved the problem with multiple layers and offsetting the y position. Thanks again for the help!
 
Top