• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE Auto Tile simply doesn't work.

R

RealityShifter

Guest
I followed the manual, and it's just not acting as expected at all. I've tried with the left top tile empty, and filled.

this happens or nothing happens.
http://imgur.com/a/nnsXH

Any advice?

I'm slowly figuring this out, but one thing I know for sure: It's really annoying that when setting up an auto tiler you can't select the top left cell of your tileset! Why is this? If you could use that top left cell you should be able to draw a tileset sprite to match the auto tile template but that simply doesn't work. So weird, please change.
 
Last edited by a moderator:

Mike

nobody important
GMC Elder
Tile 0 is "special", I've described this several times in the forum. We use it to optimise out tiles when rendering, and it helps collision checks knowing that anything !=0 is a tile. All you need to do is move your tiles down a row.
 
R

RealityShifter

Guest
Tile 0 is "special", I've described this several times in the forum. We use it to optimise out tiles when rendering, and it helps collision checks knowing that anything !=0 is a tile. All you need to do is move your tiles down a row.
Easy enough, just seems odd. Sorry to bring it up again on the forums lol.
 
You're making the same mistake. You're trying the use the special 0-tile (top-left) from your tileset. So just avoid that one and the autotile set should fill up without turning red.
 
Top