1. Hey! Guest! The 35th GMC Jam will take place between November 28th, 12:00 UTC - December 2nd, 12:00 UTC. Why not join in! Click here to find out more!
    Dismiss Notice

audio_play_sound_at update position

Discussion in 'Programming' started by Kyon, Jan 15, 2019.

  1. Kyon

    Kyon Member

    Joined:
    Jun 27, 2016
    Posts:
    471
    Heya all, I noticed that audio_play_sound_at doesn't update the position.
    Let's say, it's x,y,0, the sound doesn't move with the x and y positions, it just starts there.
    Is there a way to update the x and y positions without using emitters?


    Kyon.
     
  2. obscene

    obscene Member

    Joined:
    Jun 21, 2016
    Posts:
    2,448
    Nope, gotta use emitters. :) They aren't hard though. Create one. Play a sound on it. Move it. Destroy it in object destroy or room end.
     
  3. Kyon

    Kyon Member

    Joined:
    Jun 27, 2016
    Posts:
    471
    Bleh too bad. Thanks though.

    (any chance you know how hard those emitters are on CPU?)
    Just finished removing all emitters from my particles systems (which helped a lot)


    EDIT: also, how to destroy audio emitters. Is that the same as audio_emitter_free ?
     
  4. obscene

    obscene Member

    Joined:
    Jun 21, 2016
    Posts:
    2,448
    I doubt they have much of any effect on CPU. I use a ton and never seen anything audio-related creeping up on the profiler.

    Yes, audio_emitter_free(), I mispoke.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice