GM:S 1.4 Audio is too quiet

Discussion in 'Legacy GameMaker Community Tech Support' started by Tcloud, Jan 29, 2019.

Tags:
  1. Tcloud

    Tcloud Member

    Joined:
    Jan 29, 2019
    Posts:
    2
    I've been using GMS for over a year now and I'd say I'm fairly descent at it. But for some reason all audio in my game is extremely quiet. It still plays, but you can just barely hear anything and I'm not sure why. My best attempt at fixing this issue is to just play the same sound multiple times at the same time, but this also lowers the quality of the sound. I also tried using audio_sound_gain and sound_volume for possible solutions but they did not make any difference.


    I'm sure there isn't anything wrong with my code as I have been using this same method for audio on other projects and I had no issues there. Essentially I have music playing when the player intro animation (OBJ_player_intro) starts and it stops when the player dies, and after that I create the OBJ_player_death object which plays the player death animation. I separated these objects from OBJ_player because it is kind of necessary for what I am trying to create. I should also point out that when played back in the sound editor, the sounds are properly played at the right volume.


    OBJ_player_intro Create Event:
    audio_play_sound(SND_music01,1,0);


    OBJ_player_intro Step Event:
    //Skip Intro
    if (global.skipped = true)
    {
    audio_stop_sound(SND_music01);
    if !(audio_is_playing(SND_music_01skipped))
    {
    audio_play_sound(SND_music_01skipped,1,0);
    }
    global.wait_ms = 0;
    global.wait_s = 0;
    global.wait_m = 0;
    if (instance_exists(OBJ_text01))
    {
    with(OBJ_text01) {instance_destroy();}
    }
    }


    OBJ_player Step Event:
    //Death
    if (global.dead = true)
    {
    if !(instance_exists(OBJ_player_death))
    {
    global.locked = true;
    audio_stop_sound(SND_music01);
    audio_stop_sound(SND_music_01skipped);
    instance_create(x,y,OBJ_player_death);
    audio_play_sound(SND_player_death,1,0);
    instance_destroy();
    }
    }
     
    Last edited: Jan 29, 2019
  2. HayManMarc

    HayManMarc Member

    Joined:
    Jun 21, 2016
    Posts:
    840
    Is the volume of the sample turned up in the resource editor?
     
  3. Tcloud

    Tcloud Member

    Joined:
    Jan 29, 2019
    Posts:
    2
    Yes, all of the sound's volumes are maxed out in the sound editor. For the music though, there isn't even a volume setting so I didn't really now what to do there.
     
    Last edited: Jan 29, 2019

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice