Android APK Compile Error

Discussion in 'Programming' started by Mr Errorz, Apr 8, 2018.

  1. Mr Errorz

    Mr Errorz Member

    Joined:
    Jun 21, 2016
    Posts:
    202
    Hi,

    I am trying to make an APK for the first time on GMS2 and running into trouble..
    When I try to create a build, I get this error:

    FAILURE: Build failed with an exception.

    * What went wrong:
    A problem occurred configuring project ':com.company.game'.
    > Failed to find Build Tools revision 26.1.1

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 5.46 secs


    C:\Windows\system32\cmd.exe DONE (1)
    C:\Windows\system32\subst.exe /d X:


    C:\Windows\system32\subst.exe DONE (0)
    System.Exception: Build Failed
    at ..(YYDictionary`2 , String , String , Boolean , String )
    at Igor.AndroidBuilder.Package()
    Igor complete.
    "cmd" /c subst Y: /d

    elapsed time 00:01:47.9201900s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.1.4.200/bin/Igor.exe" -options="C:\Users\user\AppData\Local\GameMakerStudio2\GMS2TEMP\build.bff" -- Android Package started at 04/08/2018 20:48:37
    elapsed time 00:00:00.0200000s for command "cmd" /c subst Y: /d started at 04/08/2018 20:50:25
    ---------- STOPPING ----------
    FAILED: Package Program Complete

    If I understand correctly, it seems the error is: Failed to find Build Tools revision 26.1.1
    But, I do have it installed, here's a cap from my android studio, showing that 26.1.1 is installed-




    Any ideas?
     

    Attached Files:

  2. MarkGuilams

    MarkGuilams Member

    Joined:
    Dec 2, 2018
    Posts:
    19
    Have you managed to fix this error? Because I haven't... This **** sucks.
     
  3. Mr Errorz

    Mr Errorz Member

    Joined:
    Jun 21, 2016
    Posts:
    202
    I did..
    such a long time ago, so I can't remember exactly what fixed it,
    but I think it was just updating all the stuff in Android Studio, and than inputting the correct numbers in the Android options window.
    I think at one point I had it configured like this [screen], and it worked.
    Hope that helps.
     

    Attached Files:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice