Android / Amazon Fire [ANSWERED] Google Play Developer API Version v1 and v2 used by GMS2

HW.

Member


i checked my app on google play console, but it shows a message “We’ve detected that your app is using an old version of the Google Play Developer API. From December 1 2019, versions 1 and 2 of this API will no longer be available. Update to version 3 before this date.” what it means?

Clicking learn more will go to this:
https://android-developers.googleblog.com/2019/03/changes-to-google-play-developer-api.html

My app that was affected by this was developed using these details:
GMS2: IDE 2.2.2.413, and runtime 2.2.2.326
apk: armv7 and arm64


Anyone else also got the warnings?
I searched on Google many reports about this such as:

https://stackoverflow.com/questions/56700332/what-is-we-ve-detected-that-your-app-is-using-an-old-version-of-the-google-play

https://community.kodular.io/t/outdated-google-play-developer-api-version/28238/5

Some people mentioned about Google Play billing, Cloud, etc
I don't know what YoYo Games is using that might trigger this??

I am NOT using any in-app, billing, neither licensing extensions at all.

The only extension i use for the app is Admob and it looks like it doesn't use the api in question.

Please tell me if the GMS2's android built-in runner is using this outdated "Google Play Developer API Version v1 and v2" API or not?

Is 2.2.4 release already anticipating this? because I want to update my app using 2.2.4 later, if it is out of beta...

EDIT: Answered on GMS2 Google Update 2.2.4 feedback thread. It is related to the old IAP parts on 2.2.3 runtimes and below, and they say it will be solved on 2.2.4. Thanks.
Yes, this is a large part of why the Android toolchain is being overhauled in 2.2.4. That message comes from the legacy IAPs system in the runner in 2.2.3 and older. In 2.2.4, all IAPs stuff (for all stores) is also no longer part of the runner - it's purely from the extension.
 
Last edited:
Top