• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android severe framerate drop

ViceVersa

Member
so, i think i saw this on a thread on reddit once, but about 30 or 40 seconds into my game there is a severely noticable framerate drop that seems to be caused for no reason. ive read that adding "application_surface_enable(false)" would fix the lagging problem, but there is absolutely no difference, I dont think this is caused by application surfaces. Im not really drawing much other than the score, lives, and a joystick. Ive tested this out in Windows executables and it works perfectly fine, all of the old gameobjects in my game are destroyed almost immediately when theyre off screen, I dont think this is a coding error on my part as there is nothing intensive going on in the game when the lag starts, the game just gets slower and slower as you play, regardless of which room youre in. Has anybody found a fix for this? I just updated my phone today to verison 7.0 in case that matters, same result.
 

Simon Gust

Member
so, i think i saw this on a thread on reddit once, but about 30 or 40 seconds into my game there is a severely noticable framerate drop that seems to be caused for no reason. ive read that adding "application_surface_enable(false)" would fix the lagging problem, but there is absolutely no difference, I dont think this is caused by application surfaces. Im not really drawing much other than the score, lives, and a joystick. Ive tested this out in Windows executables and it works perfectly fine, all of the old gameobjects in my game are destroyed almost immediately when theyre off screen, I dont think this is a coding error on my part as there is nothing intensive going on in the game when the lag starts, the game just gets slower and slower as you play, regardless of which room youre in. Has anybody found a fix for this? I just updated my phone today to verison 7.0 in case that matters, same result.
Do you have show_debug_message() somewhere in your code?
 

ViceVersa

Member
yes, its a space shooter game so every time the player shoots it creates a new laser object, and every time it colides with an enemy it creates explosion particles
 

ViceVersa

Member
though, to be a little more specific, the framerate never picks back up, its not like it just slows down when there are particles, it slows over time and just keeps getting slower regardless of the room (including the game over screen where nothing is being created or destroyed)
 

acidemic

Member
Looks as if the perfomance problem has been fixed in the latest Early Access build Version 1.99.551

As it says in the release notes: https://www.yoyogames.com/downloads/gm-studio-ea/release-notes-studio.html
Misc In-Game: Disabled Scissoring testing of surfaces on mobiles (in most cases), gives a decent performance boost on some devices

Can you test this and tell if it worked? I am going to complile my own game and test it on the Samsung Galaxy S3 later this week to see if there is a significant improvement.


P.S.:
This GMS slowdown on Android already forced me to heavily optimize my game and to start using "delta_time". :)
 
Top