• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire Android problem

aGameDev

Member
Hey @Marko03970 did you ever figure this out?

Today I tried updating to the most recent SDK versions and I got the same error when trying to compile.

Previously I was using these values (in Global Game settings for Android), and it seemed to work ok:

Target SDK: 26
Min SDK: 14
Compile SDK: 26 (That's Android 8)
Build Tools: 26.0.3
Support Lib: 26.0.0


What I tried today was downloading these newer versions and making these settings:

Target SDK: 29
Min SDK: 14
Compile SDK: 29 (That's Android 10)
Build Tools: 29.0.0
Support Lib: 29.0.0
(I also tried just plain "29" for both those values, without the .0.0, because that's how it appears in the SDK manager)

In Android SDK manager I was sure to get the "SDK Build Tools rev 29" (and I already had the support Repository, of course).
For "Support Lib," as far as I can tell, you just have to use the same version as Build Tools in this case -- at least that's what this page seems to indicate: https://help.yoyogames.com/hc/en-us/articles/216753418-GameMaker-Studio-Global-Game-Settings-for-Android

Though I note that this page: https://help.yoyogames.com/hc/en-us/articles/216753748-GM-S-1-4-Required-SDKs
says, "Note: Support libraries are not listed in SDK Manager anymore, but you can find them here [your Android SDK install folder]\extras\android\m2repository\com\android\support\support-v4"

But if I check that folder, I only see subfolders going up to version "26.0.0-alpha1" -- and that "26.0.0" was the previous value I was using, as I noted above (and there are no other "26" folders).



In any case, when trying to compile I get this:

Code:
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring project ':com.tinyvast.PogoPiggle2'.
> Could not resolve all dependencies for configuration ':com.tinyvast.PogoPiggle2:_debugApkCopy'.
   > Could not find com.android.support:support-v4:29.0.0.
     Required by:
         project :com.tinyvast.PogoPiggle2
   > Could not find com.android.support:support-v4:29.0.0.
     Required by:
         project :com.tinyvast.PogoPiggle2 > com.google.android.gms:play-services-games:11.8.0 > com.google.android.gms:play-services-basement:11.8.0

I guess I (or we?) might have to stick with building for Android 8, unless you figured out how to address this issue. Though I haven't tried building for Android 9....

It's possible we just don't have the right Support Lib version number it's looking for... but how are we supposed to find that?
 

aGameDev

Member
For what it's worth, I have found that these versions work:

Target SDK: 28 (Android 9)
Min SDK: 14 (This is minimum required for the Google Play Services extension I am using)
Compile SDK: 28
Build Tools: 28.0.3 (be sure to download this separately from SDK manager, of course)
Support Lib: 28.0.0 (this just... is included with other things you should already have, apparently)

So, Android 9 SDK may be the highest version supported by GMS 1.4, at least from my experience.


Though, I note that the first time I tried to compile with these versions, it failed with an error about java (it did seem to download a lot of java things during compile), but I then cleaned the target (broom icon) and tried again and it compiled successfully.

And as another note... it ALWAYS pops up a window that says "compile failed" yet in the compile area in GMS it says BUILD SUCCESSFUL, and indeed the APK is created. I guess it's possible it thinks the compile failed because the process ends with an error about "no devices or emulators found" or something, which I think is related to sending the APK to the YoYo Runner app... which I haven't been using.
 
Top