Android not working? help me

Discussion in 'Programming' started by TomCartwright, Aug 15, 2019 at 9:48 AM.

  1. TomCartwright

    TomCartwright Member

    Joined:
    Wednesday
    Posts:
    4
    FAILURE: Build failed with an exception.
    * What went wrong:
    A problem occurred configuring project ':com.company.game'.
    > Could not resolve all dependencies for configuration ':com.company.game:_debugApkCopy'.
    > Could not find com.android.support:support-v4:29.0.0.
    Required by:
    project :com.company.game
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    BUILD FAILED
    Total time: 2 mins 4.819 secs

    C:\Windows\system32\cmd.exe DONE (1)
    C:\Windows\system32\subst.exe /d V:

    C:\Windows\system32\subst.exe DONE (0)
    Error : Build Failed
    Igor complete.
     
  2. NoFontNL

    NoFontNL Member

    Joined:
    Feb 10, 2018
    Posts:
    287
    As you may know, to build android applications you need android build tools, you need to download the support library 29.0 via SDK manager
     
  3. TomCartwright

    TomCartwright Member

    Joined:
    Wednesday
    Posts:
    4
    I'm trying it's now saying

    A problem occurred configuring project ':com.company.game'.
    > Could not resolve all dependencies for configuration ':com.company.game:_debugApkCopy'.
    > Could not find com.android.support:support-v4:29.0.0.
    Required by:
    project :com.company.game
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    BUILD FAILED
    Total time: 14.318 secs

    C:\Windows\system32\cmd.exe exited with non-zero status (1)
     
  4. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    4,304
  5. TomCartwright

    TomCartwright Member

    Joined:
    Wednesday
    Posts:
    4
    So I have to unzip and install every package from SDK for every version of Android...? I preferred using the older GM Studio, it worked then..
     
  6. TomCartwright

    TomCartwright Member

    Joined:
    Wednesday
    Posts:
    4
    I'm installing all Obsolete packages now
     
  7. FrostyCat

    FrostyCat Member

    Joined:
    Jun 26, 2016
    Posts:
    4,304
    You don't need all the different versions. At this moment, just API level 28 is enough to get you started.
    I got mine working without any of the obsolete packages.

    Seriously, read the Helpdesk's instructions and don't just install everything blindly.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice