Android Android NDK throwing error in YYC Compile

Discussion in 'GameMaker Studio 2 Community Tech Support' started by DyadGames, Nov 3, 2018.

  1. DyadGames

    DyadGames Member

    Joined:
    Jul 16, 2016
    Posts:
    31
    Getting this compile issue on YYC compile. Its saying something about the NDK but Im using the recommended android-ndk-r17c. I also tried the newest 18 just to see but it failed differently. It says something about the APP_ABI definition but I cant seem to find it.

    Anyone else have this issue or know whats up? Cheers.

    Code:
    ...
    Final Compile...finished.
    Looking for particle images in U:\bin\\ParticleImages
    Writing Chunk... GEN8
    option_game_speed=60
    Writing Chunk... OPTN
    Writing Chunk... LANG
    Writing Chunk... EXTN
    Writing Chunk... SOND
    Writing Chunk... AGRP
    Writing Chunk... SPRT
    Writing Chunk... BGND
    Writing Chunk... PATH
    Writing Chunk... SCPT
    Writing Chunk... GLOB
    Writing Chunk... SHDR
    Writing Chunk... FONT
    Writing Chunk... TMLN
    Writing Chunk... OBJT
    Writing Chunk... ROOM
    Writing Chunk... DAFL
    Writing Chunk... EMBI
    Writing Chunk... TPAGE
    Texture Group - Default
    Writing Chunk... STRG
    Writing Chunk... TXTR
    0 Compressing texture... writing texture texture_0.png...
    1 Compressing texture... writing texture texture_1.png...
    2 Compressing texture... writing texture texture_2.png...
    3 Compressing texture... writing texture texture_3.png...
    4 Compressing texture... writing texture texture_4.png...
    5 Compressing texture... writing texture texture_5.png...
    6 Compressing texture... writing texture texture_6.png...
    7 Compressing texture... writing texture texture_7.png...
    8 Compressing texture... writing texture texture_8.png...
    9 Compressing texture... writing texture texture_9.png...
    10 Compressing texture... writing texture texture_10.png...
    11 Compressing texture... writing texture texture_11.png...
    12 Compressing texture... writing texture texture_12.png...
    13 Compressing texture... writing texture texture_13.png...
    14 Compressing texture... writing texture texture_14.png...
    15 Compressing texture... writing texture texture_15.png...
    16 Compressing texture... writing texture texture_16.png...
    17 Compressing texture... writing texture texture_17.png...
    18 Compressing texture... writing texture texture_18.png...
    19 Compressing texture... writing texture texture_19.png...
    Writing Chunk... AUDO
    ClangExeLocation=C:\Android\android-ndk-r17c\toolchains\llvm\prebuilt\windows-x86_64\bin\clang++.exe
    Using NDKDir = C:\Android\android-ndk-r17c
    Using PlatformDir = C:\Android\android-ndk-r17c\platforms\android-28
    Using ARMToolChain = C:\Android\android-ndk-r17c\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64
    Using ARM64ToolChain = C:\Android\android-ndk-r17c\toolchains\aarch64-linux-android-4.9\prebuilt\windows-x86_64
    saving file V:/PetProject_E7EFD4_YYC\PetProject.droid
    Android NDK: The armeabi ABI is no longer supported. Use armeabi-v7a.   
    C:/Android/android-ndk-r17c/build//../build/core/setup-app.mk:79: *** Android NDK: Aborting    .  Stop.
    Android NDK: NDK Application 'local' targets unknown ABI(s): armeabi   
    Android NDK: Please fix the APP_ABI definition in C:/Android/android-ndk-r17c/build//../build/core/default-application.mk   
    Stats : GMA : Elapsed=39345.7904
    Stats : GMA : sp=468,au=122,bk=0,pt=1,sc=2691,sh=5,fo=22,tl=0,ob=282,ro=33,da=21,ex=18,ma=250,fm=0xF668B79F7FFF7FB5
     
  2. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    229
    What architecture are you building for on android? In options >> android....when you click the architecture options what is shown ticked? Try building only to arm7, x86x64, arm64, and unselect the rest.
     
  3. DyadGames

    DyadGames Member

    Joined:
    Jul 16, 2016
    Posts:
    31
    Ah that seems to be pushing through. I had Armv5, Armv7, and I believe Arm64. I'm now using arm7, x86 and arm64 and it seems to be compiling.

    I just dont want to miss out on some of the older devices market share but it would seem Armv7 covers almost everything. Do you know anything about this @Amon?

    Cheers!
    Alex
     
  4. Amon

    Amon Member

    Joined:
    Sep 13, 2016
    Posts:
    229
    Glad that worked for ya. :)

    Well, arm5 is not even worth it as the devices are old, slow and probably wouldn't do you any favours review wise. It's nearly obsolete. I wouldn't worry about arm5 at all. 98% of devices today are arm7, arm64 etc.
     
    HW. likes this.
  5. Pushloop

    Pushloop Member

    Joined:
    Jun 22, 2016
    Posts:
    149
    Just curious, where do you see arm64 in the list? I only see arm5,7, x86 and mips.

    Weird, i got it once and now they're gone again. What is influencing the architecture tab?
     
    Last edited: Nov 4, 2018
  6. HW.

    HW. Member

    Joined:
    May 21, 2017
    Posts:
    198
    since 2.1.5+ IDE and runtime... there are x86_64 and arm64 and mips64

    especially 2.2.0 ide and runtime, i am sure it is there the ticks for the 64bits.

    I don't know for 2.2.1 as i don't install it yet (still beta).

    What IDE version of GMS2 are u using? and the Runtime version?
     
  7. Pushloop

    Pushloop Member

    Joined:
    Jun 22, 2016
    Posts:
    149
    Ah thanx, that makes sense. Had various IDE's but had to roll back to 2.1.4 so it would build for nexus
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice