• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire Android export and Google Play compatability [Solved]

Hax4Ever

Member
Android export thus far has been nothing but a struggle for me, It took me some digging on these forums and the old forums to find out how to just get it to build, and about a week after getting that working and getting ready to put a product on the app store, I'm now wrestling with app bundles.


Simply put : I can't figure out for the life of me how to make the game build with the requirements for the Play Store.

I've been following the official guides and still haven't been able to build properly, in fact, after following the guide to help with the app bundles, it's been functioning less.

The guide was a little confusing and vague when it said:
Now you need to ensure your Android tools folders are part of the PATH variable set for the system, which is done in the second panel of Environment Variables:
Note, it said Folders, and the path variable seems only to be designed to link to one folder.



Here are also the settings that I needed to apply outside of the IDE


And of course, here is the GMS2Temp folder that should contain the output.



The folder does NOT contain the APK, no apk was built, but there is a .droid file.

Any help would be appreciated, I'm aware that a fix should be coming with 2.2.4 for both issues I came across with Android export thus far, but I still need to begin testing and get this port done as soon as possible.

Edit: Upon trying to build using windows export on something else, that doesn't work either. Why did the tutorial guide me to make changes that would plainly disallow me from testing and building my own code?
 
Last edited:

pipebkOT

Member
@Hax4Ever

And of course, here is the GMS2Temp folder that should contain the output.
where did you get that the output should be there?


quoting the guide that you are using https://help.yoyogames.com/hc/en-us...ate-An-App-Bundle-For-Google-Play-Submissions

it should be in:
  • %appdata%\GameMakerStudio2\Cache\GMS2CACHE\[project name]\Android\default\[package name]\build\outputs\apk\release


gms2temp folder is never mentioned in the guide.






Upon trying to build using windows export on something else, that doesn't work either. Why did the tutorial guide me to make changes that would plainly disallow me from testing and building my own code?
if you want to revert the changes and test in windows , just delete the runtime and download it again.
 
Last edited:

pipebkOT

Member
edit,

yeah, it seems like the apk has not been compiled correctly.


Android NDK: android-14 is unsupported. Using minimum supported version android-16

change the minimum sdk in the project settings to 16 instead of 14 . and uncheck "run lint code analysis"




Code:
Using PlatformDir = C:\Users\Hax4Ever\AppData\Local\Android\Sdk\ndk-bundle\platforms\android-29
also please don't target android api level 29 (android Q), is not even released yet. it's on beta,
 
Last edited:

Hax4Ever

Member
also please don't target android api level 29 (android Q), is not even released yet. it's on beta
I wasn't targeting api level 29, it shows I'm targeting 28

Adjusted 14 to 16, disabled lint code analysis...
Cleaned cache, attempted a build, and it still brought up 14 fsr.

Restarted...
Cleaned and tried again.
upload_2019-8-15_21-35-7.png

Same issue as last time.

Compile log (Hastebin)
 

Hax4Ever

Member
Click the refresh button, you should get a list of runtimes to choose from which you can then double click to install.
Tried refreshing yesterday and today, no runtimes are listed...

EDIT:
Switched themes, now there's runtimes.
 
Last edited:

Hax4Ever

Member
Alright so after changing runtimes and building again, no progress from the last one, it built and didn't give me an APK.
 

pipebkOT

Member
The guide was a little confusing and vague when it said:
Now you need to ensure your Android tools folders are part of the PATH variable set for the system, which is done in the second panel of Environment Variables:
Note, it said Folders, and the path variable seems only to be designed to link to one folder
if you see the image , you can notice that "path" accepts multiples folders in a list and separate them by a ";"

thats why you need to add them to the "list" and then press "ok", but without deleting the existing paths.

but you deleted the original path, thats why it keeps showing that error

 
Last edited:

Hax4Ever

Member
if you see the image , you can notice that "path" accepts multiples folders in a list and separate them by a ";"

thats why you need to add them to the "list" and then press "ok", but without deleting the existing paths.

but you deleted the original path, thats why it keeps showing that error

Alright I did that.

Now it crashes again.

Crash log (Hastebin)
 

pipebkOT

Member
you are missing the android sdk"platform-tools" path too

and the original oracle/java/javapath, you know......, the one you deleted xD and caused all the problem
 
Last edited:

FrostyCat

Member
You have been told that "subst is not recognized" is a blocker. Add C:\Windows\system32 to your PATH environment variable to get rid of that.
 

Hax4Ever

Member
That seems to have worked, but it didn't throw an error at the end like the guide suggested it should.

I tested the apk(s) with Google Play and got the same error I would've gotten if I just compiled this regularly.

upload_2019-8-17_16-22-37.png

So now I'm back at square one.
 

FrostyCat

Member
That's a warning, not an error. Google Play shows that message whenever it sees a big APK. As long as you get an APK that runs, then you've succeeded.

It doesn't mean you don't have anything else to check, though. For starters, try removing needless architectures (e.g. x86, x86_64) or graphics/sounds that are not being used.
 

pipebkOT

Member
or compress the sounds instead of using uncompressed sounds. uncompressed sounds are the culprit of bloated apks

--------------

if you still want to make an aab
did you get the gradle warning ? you say that not, so you need to do the editing and downloading gradle part, and make sure that your are doing it in the runtime that your are using.
modifying the android runner


"
Now, compile your APK for the Android target inside GMS2 as normal. Note that we want to see the build succeeded and also reference that you were using gradle 5.1.1:

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.1.1/userguide/command_line_interface.html#sec:command_line_warnings


BUILD SUCCESSFUL in 1m 37s
"



If you don't get this (i.e., your whole build process worked), then you have not applied the runtime changes and installed the new gradle files correctly, and so you would have errors when trying to generate the bundle file later on in this guide.


after that you need to do the cmd part and all of that, so, re-read the guide and continue
 
Last edited:

Hax4Ever

Member
did you get the gradle warning
Forgot to mention that I did.

Build Log (Hastebin)

I checked the gradle, and yeah, I did have the changes from the article already applied.

I wanna note that the apks were located in the different directory (rather than the specified one)

Attempting to use the subst command in cmd throws an 'invalid parameter - [whatever letter I put in]' error at me

Edit : I'm stupid, let me just try doing the cd stuff since I'm not including google play services
 

Hax4Ever

Member
So after a few days of guidance, I was finally able to get Google Play to accept the file.

Thanks to everyone that helped me with this, I hope this thread will be useful to people in the future that come across this issue. (Atleast 'till 2.2.4 when these issues are hopefully fixed)
 
Top