• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android / Amazon Fire Android compilation error: "Requires newer sdk version"

Hey, I've been trying to set up GameMaker to be able to test games on my android. I followed a tutorial for setting up SDK/s etc. Everything looks good to me, but I get this error:

adb: failed to install Z:/puzzlegame_E2F8CEF8\puzzlegame_armeabi-v7a_arm64-v8a_v1.0.0.apk: Failure [INSTALL_FAILED_OLDER_SDK: Failed parse during installPackageLI: /data/app/vmdl373525418.tmp/base.apk (at Binary XML file line #9): Requires newer sdk version #29 (current version is #28)]

It says that I need sdk 29, but I have sdk 29. What could cause this?

Thank you very much for any help!
 
Last edited:
Top