• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Android Android API 30/NDK 21 compiling output error: arm-linux-androideabi-strip: unable to rename

superfuzz

Member
Please help!

I tried searching around for this issue and haven't found any correct solutions yet...
I'm trying to compile my game using YYC for Android devices using the latest Gamemaker 2.3.3.570 and runtime 2.3.3.434
I have Andriod Studio 4.2.2
API level 30.0.3
NDK 21.4.7075529

The "Output" error I keep getting no matter what I've tried so far:


[armeabi-v7a] Install : libyoyo.so => U:/Blimps_383213F3_YYC/lib/armeabi-v7a/libyoyo.so
C:/Android-SDK/ndk/21.4.7075529/build//../toolchains/llvm/prebuilt/windows-x86_64/bin/arm-linux-androideabi-strip: unable to rename 'U:/Blimps_383213F3_YYC/lib/armeabi-v7a/libyoyo.so'; reason: Permission denied
make: *** [C:/Android-SDK/ndk/21.4.7075529/build//../build/core/build-binary.mk:774: U:/Blimps_383213F3_YYC/lib/armeabi-v7a/libyoyo.so] Error 1
make: *** Waiting for unfinished jobs....
[arm64-v8a] SharedLibrary : libyoyo.so
Stats : GMA : Elapsed=227029.1427
Stats : GMA : sp=724,au=14,bk=4,pt=0,sc=76,sh=0,fo=22,tl=0,ob=892,ro=98,da=0,ex=0,ma=958,fm=0xB20D69EE2620
T://bin/GMAssetCompiler.exe exited with non-zero status (2)


Not sure what is happening?
-I've tried running Gamemaker as an Administrator.
-I clean the project, each time before I attempt compiling.
-It compiles/launches using Andriod VM runner just fine.
-Not sure if this is related to the new IDE release or not?
-I've tried turning it off and back on again.

Any help or ideas to attempt is most appreciated, thank you in advance!!!
-Ed
 

Mert

Member
This happened to me sometime ago, I don't remember how I solved this.
But I remember clearing out the caches (Deleting the files)

Additionally, you might want to check if your antivirus blocks anything. You can also try to reinstall the game
 

superfuzz

Member
Mert,

Thank you for your quick response!
I tried disabling the anti-virus and no dice, and as far as I know when you "clean" the project that clears out the caches (unless there's another spot that this needs to be done?)

In the meantime, I'll try reinstalling the latest Gamemaker and triple-check all the Android setup stuff. Thanks!
-Ed
 
Top