• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

SOLVED All Sequences have a chance to loose objects/sprites trackts on run, Project file and how to best avoid it included

Update- Great news! The bug has been fixed as of 2.3.2!

Update-

This project file shows a critical bug in gamemakers sequences and how to best circumvent the bug.
The more objects in a sequence, the more likely gamemaker will randomly lose ones location on running the program.

To test this issue simply run the program a few times, and you'll see random objects displaced off the grid each time. As someone who
has seen sequences run thousands of times while developing I can say this error can happen with any sequence, its just the more individual
tracks in a sequence the more often it will happen.

If a sequence loses an object restarting the game won't fix the issue( Press R to see for yourself), nor is it a issue created on compile.
Exe files will randomly on launch have a chance to loose objects(Try creating a EXE and running it a few times.)

The solution- Nested Sequences. Nesting a sequence in a sequence is much safer and seems to also runs with better performance in gamemaker.
(Check the test room to toggle on Sequence 32x32, a series of nested sequences.)
Since each sequence is only 4 tracks its very unlikely for this error to occur.

Old Post-
My friend has been making animations using sequences.
It works well as a flash like system for animating character movement.
Or for creating coordinated movement for lots of objects
Its been great, I've helped find work arounds for most bugs but there's one that haunts me.
Sometimes when you run the EXE, or Run in gamemaker
One of the sequences will replace one object with another. Some of the random replacements can be bizarre like swapping glasses for a nose, or swapping the chest for a leg.
Normal.png vs Cursed.png
Restarting the game doesn't work, it has nothing to do with the cache or whether any code is being run.

Sometimes when a user starts the EXE it will load a sequence incorrectly, sometimes it won't.
Its Schrodinger's Sequence Objects. I don't know whether it bugging out until the user runs the program.
This makes it impossible to use sequences for any kind of professional project.
I've tried contacting yoyo's bug reporter about it over and over but gotten no response.
I haven't seen anyone talking about the issue online.

Protips to repoduce the bug- Create a sequence, drop a lot of objects in it. The more object the higher chance you'll get of seeing the bug. So go big. Make gamemaker lag under the weight of your Copy Paste skills.
Then drop the sequence in a room, create an EXE and run the EXE,close it and open it again until you see one of the objects you placed in the room has been replaced by another object
 
Last edited:

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
This definitely sounds like a bug. When you filed the bug report did you include a link to a project that shows the issue? Bugs reported without downloads to test will take longer to be cleared as the QA team has to make tests, but if you include a link then they just have to use your project. :)
 
I created a project file to showcase 5 different sequence bugs on windows and html5 and submitted a report over a month ago. I have done follow up messages. Still haven't gotten even a reply.
 
I've updated the post with a project file that clearly shows the bug and a solution I've found to best circumvent it for now. I'm putting all important information at the top, and changed the topic to be more easy to find in case someone else is searching for a solution to the issue.
 
Hey, thank you for sharing the nested sequences fix. I'm making a game with a lot of sequences and almost every time it runs there is at least one sequence with an item missing.
 
Heads up looks like the latest update fixed this. If I run your ShrodingersSequence game both of the example sequences run fine. 32x32 flickers, but that looks like it's just resetting so idk if that's an issue or not.
 
Good Catch.
Yes, it is an issue, from my tests I've found that now all nested sequences flicker on loop.
We'll have to report this bug as well.
 
Top