• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

After updating; manual is not loading

E

Eisot

Guest
A simple issue it seems but I can't get to the manual after updating to 1.4.1763.
Am using the online manual but it's so very convenient hitting F1 instead.
Please help find my manual. :confused:
 
C

CuG

Guest
Try hitting F1 or loading the Manual from the Help menu the first thing after loading Studio before you do anything else.

On my machine when I run a Windows targeted game, the system's %TEMP% folder gets deleted after Runner.exe exits which makes the Manual not open anymore since it needs the %TEMP% folder.

I first noticed this deletion problem when my Manual was not loading!
 
Last edited by a moderator:
E

Eisot

Guest
Thank you both for the suggestions!
I re installed GM and opened the manual first thing. Works great now. :)
 
C

CuG

Guest
As a test, try not opening the manual the first thing after opening Studio and then compiling/running a Windows target from Studio. Then see if the manual loads.

If it does not load, then your %TEMP% folder was deleted and there's a bug in Runner.exe or Studio.
 
E

Eisot

Guest
As a test, try not opening the manual the first thing after opening Studio and then compiling/running a Windows target from Studio. Then see if the manual loads.

If it does not load, then your %TEMP% folder was deleted and there's a bug in Runner.exe or Studio.
You are right, manual doesn't load any more after running Windows target. :(
Have you bug reported this?

--- edit ---
And the "C:/users/name/AppData/Local/temp" folder does not exist.
 
J

jackhigh24

Guest
i reported this a few versions back and it got fixed, so looks like this version has broke it again.

EDIT
i just tested it and it does work, so something wrong with your install.
 
Last edited by a moderator:
E

Eisot

Guest
I'm in email dialogue with support now so am sure it will get solved. :)
 

Ethanicus

Ethan L!
I'm having a similar issue, except the manual opens across both my monitors and loses its formatting, instead showing as just plain text.
 
E

Eisot

Guest
I'm having a similar issue, except the manual opens across both my monitors and loses its formatting, instead showing as just plain text.
Yes, something is going on with loading the manual. I will comment here when it is fixed or we have found what I have done wrong. ;)
 
E

Eisot

Guest
Only a temporary one - restarting the computer and after starting GM:S I start the manual, first thing, and keep it open in the background until I am done. :)
 

Bingdom

Googledom
This might depend on what windows you are running on. I'm currently using windows 7 and I'm not experiencing this.
 
C

CuG

Guest
It works after you reboot because the system's TEMP directory is recreated on startup.

And if you open the GM Manual first thing the manual places two open files in the system TEMP directory which keeps whatever in GM from deleting the directory. Any other unlocked files in the TEMP directory belonging to other applications will also be deleted by GM including temporary browser files if you have an internet browser open which can lead to browser weirdness.

I did a complete wipe (files, folders and registry) and re-install of 1.4.1763 GM studio and GM's deleting-TEMP-directory problem was still there.

Somewhere in the GM Studio source code there is an extra "../" when it goes to delete its "scoped" folder that GM places in %TEMP%.

See my other post in this forum topic titled "Studio deletes system TEMP folder after run of Windows target." There is a .BAT file in that post that you can use to start GM Studio pointing to a temporary TEMP folder :rolleyes: which is kept from being deleted by automatically opening the GM Help file.
_____
Vista SP2 64-bit.
 
Last edited by a moderator:
F

Fritz

Guest
Hi guys, I'm trying to take a look at this issue, but haven't been able to reproduce it - could you provide me with a screenshot of your Preferences->General like the attached? And if you could include the complete CompileForm output from a windows run it should give me a better idea what is going on.

Thanks, Fritz


Capture.PNG
 

BlueSlime

Member
so yeah this, bug is still there in v1.99.525 my manual won't open on F1 or middle click nd I don't feel like restarting windows right now but I will in a bit =/ I hope this gets fixed

I'm using windows 10 64bit and gm v1.99.525 and windows target
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
@ALL with this issue:

Hi guys, I'm trying to take a look at this issue, but haven't been able to reproduce it - could you provide me with a screenshot of your Preferences->General like the attached? And if you could include the complete CompileForm output from a windows run it should give me a better idea what is going on.
;)
 

BlueSlime

Member
Ok well...I found just now that if I close the EA v1.99.525 and then open the v1.4.1757 and press F1 it works....

then close that one and reopen v1.99.525 then F1 the help manual opens again WITHOUT having to restart my entire system. :] then I guess I'll just leave it open while I'm working in GM
 

Appsurd

Member
I had the same issue on Windows 10. While opening the manual, it sometimes tried to open it but failed. And after a few times tryng, it showed the message: "Preparing index for first use.".

My solution was to manually add the folder "temp" to Appdata\Local.
 

RangerX

Member
So is this thing fixed or not?
Having to restart or create a temp folder is NOT a solution. Am still having this bug in 7772.
 

Nocturne

Friendly Tyrant
Forum Staff
Admin
Moderator
In windows explorer, use RMB on the CHM file and select Properties. Make sure that "UnBlock" is checked...

upload_2017-8-31_15-3-26.png
 
N

NeonBits

Guest
I dont have time to read all this and reading "fixed" then "has returned" tells me I shouldn't.
So I have the same bug. Manual doesn't open. In the beginning, it crashed GM when clicking open twice. It didn't happened last time when clicking but manual still doesn't open.
 
W

Wraithious

Guest
Hi guys, I'm trying to take a look at this issue, but haven't been able to reproduce it - could you provide me with a screenshot of your Preferences->General like the attached? And if you could include the complete CompileForm output from a windows run it should give me a better idea what is going on.

Thanks, Fritz
gmspecs.png

Here's a screenshot as you requested, I'm running windows 10 creator's edition on a 2 year old 4 core dell laptop with the stock radeon graphics card.
I don't know of this is related or not but usually when this happens to me other things are also happening along with it, I suspect it's some kind of memory allocation issue, to explain what I mean this is the order things go from good to bad:
1. after several test runs of a game the manual won't open any more
2. after that if I have an object window open and click the tooth brush (clean project) button the information box "Target cleaned" most of the time appears UNDER the object properties window so you have to cycle the task bar a few times to click OK.
3. Now things start getting weird, sometimes if I click a resource to edit, doesn't matter if it's a sprite or object or whatever, the wrong edit resource box will open!
4. If switching from windows mode to android the compiler can't find my android device
5. if in android mode and try to test build a project I get an error "can't create file system"
6. Then finally I get a message saying I have a stale temp file and should clear it, so I clear it and clear the cache too I get a "memory low on resources" error

The only way to solve any of these errors is to restart my computer, not just gamemaker, my whole computer has to be restarted.
 
N

NeonBits

Guest
Sorry, trying to understand how GM works takes all of my time. But better late than never.

 
N

NeonBits

Guest
I think this could be linked to explorer? I opened explorer and then clicked the manual icon in GM and it worked. I copied and pasted the 5pice.chm to desktop and now GM opens the manual without needing explorer opened.

Edit: said that too fast. I opened the comp today, explorer was closed, and manual icon didn't respond even after opening explorer. But 5pice.chm on desktop is great!
 
Last edited by a moderator:
Top