GM:S 1.4 Ads showing in local build but not showing from Play Store

Discussion in 'Legacy GameMaker Community Tech Support' started by Penninha, Dec 16, 2018.

  1. Penninha

    Penninha Member

    Joined:
    Dec 16, 2018
    Posts:
    1
    Hi all!

    I've been struggling to get ads to work within my project in 1.4. Here is the problem:

    I downloaded the GooglePlayServices extension for GMS 1.4 and got everything working using TestAds AND Real Ads from my local build (which I mean with local is to plugging my phone into my PC and let the GMS copy the APK to my phone when it finishes to build).

    The problem starts when I download the game from the Google Play. For some reason the Ads don't show when the APK is from there. I've tested from my phone and from my girlfriend's phone.

    One thing I noticed is that when I run with the debugger, or the CMD thing that GMS starts when copy the APK to phone, when I run the Google Play's APK at the time it will show the Ad, it shows a message which say: "APK without sufficient permission to get location" and bellow that shows "AdFailed to load: 3".

    But the weird thing is: in Google Play the APK has the ACCESS_COARSE_LOCATION in the permissions section when I got detailed view from APK.

    Someone have been through something like this? Because I don't know what to do.
     
  2. Tigas

    Tigas Member

    Joined:
    Jun 22, 2016
    Posts:
    21
    I was with a blocker of advertisements installed on the cell phone so it was not appearing the banners, I do not know if this is your case : V
     
    Last edited: Dec 25, 2018
  3. zmads

    zmads Member

    Joined:
    Mar 2, 2017
    Posts:
    80
    Did you found a solution for that? I'm probably having the same problem
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice