1. Hey! Guest! The 32nd GMC Jam will take place between Feb 22nd, 12:00 UTC (Friday noon) and Feb 25th, 12:00 UTC (Monday noon). Why not join in! Click here to find out more!
    Dismiss Notice

Feedback Added custom fonts not showing in font dialogue box

Discussion in 'GameMaker Studio 2 Community Tech Support' started by UriMax, Nov 19, 2018.

  1. UriMax

    UriMax Member

    Joined:
    Nov 17, 2018
    Posts:
    4
    Hello there,

    I also posted this in another topic feathuring a different but similar problem (because I guess internally related). But I guess I'm not the only one it ever happened to.
    So I'm just putting this here because this error will have a specific topic, and people can post their own solution.

    DISCLAIMER
    It worked for me : I'm not assuming it can work for everyone.
    And be wary of not deleting any system font....or you'll get a beautiful not loading windows black screen.
    Hence, I'm posting that solution here as a possible mean to an end.
    You can jump to the second point directly, I'll just be explaining the backstory.

    1 - My problem :

    It occured after a fresh install on W10, and installing all my fonts manually in the "Windows/fonts" folder. opening a project with custom fonts.
    When trying to change the font file used for one of the created font, GMS gave me an error before I could even do anything, just by entering the dialog box.
    It could not find the font. As in "does not exist" font. Yet, opening the windows font folder, IT DID exist, and yes, I had installed it (and many more).
    Scrolling down the menu, there was actually NO TRACE WHATSOEVER of any of the fonts I had installed before hand, right after my fresh W10 install.

    I figured "Might as well try a font manager to see if there's a problem" and went for NexusFont. First time I used that software.
    And....SURPRISE it could not find any of my font as well !!!

    2 - On to said method.
    Let's delete them all one by one !
    Went down the scrolling menu, it was the exact same thing as the list from NexusFont for my font folder contents.
    Went to said folder, and first, I copied all the fonts not showing in a new folder on my desktop (can be anywhere else, doesn't matter).
    Then I manually deleted all these fonts from the windows/font folder.
    !!!!!! DO NOT DELETE ANY SYSTEM FONT !!!!!!
    I open NexusFont back, and after a quick search on the internet, figured out how to install fonts. Just right click on "Sample group" --> "Add Folder".
    Select the folder where you put your custom fonts.
    Once in the list, Ctrl+A to select them all, right click ---> "INSTALL" in the windows/font folder.
    I did a Windows restart here for good measure.

    Back into GMS after the restart......and voila, it worked.

    3 - Conclusion

    I'm not sure if I will ever encouter the same problem. Hope not.
    And I used NexusFont only for this problem, I'm not trying to advertise any soft, I don't use it (even if I can figure it has its use for people working with fonts or for writing puroposes).

    I hope it solved your problem.
     
  2. Cowlord

    Cowlord Member

    Joined:
    Jun 29, 2017
    Posts:
    54
    Was having problem after fresh windows install where new fonts werent showing up in GMS2 (and only GMS2)... installed and launched NexusFont and didn't touch a thing and boom GMS2 detected a font change and asked to reload!

    Thank you!!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice