• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE 50-55% CPU Usage doing nothing in 2.0.4.64?

rwkay

YoYo Games Staff
YYG Staff
There is a new build out now which should fix this... just restart to be prompted to download it

Russell
 

LarryP

Member
GM2 30%, Unity3D 5%. Win7 Pro 64 bit, 24 gigs ram, i7 3.2, Radeon HD 5800. YoYo, you guys are the best. Glad you have this worked out! Downloading now...

Update after install: GM2 1-2%. Good job!
 
Last edited:
B

bobula13

Guest
Working great for me now. CPU usage averages at 2.5%, the max so far being 4%. Thanks for the quick fix!
 

WarpDogsVG

Member
I think there's still a leak somewhere. It definitely starts out fine, but after some usage (maybe an hour?) the idle CPU goes back to crazy - hovering around 45-50% with no activity. Here's a screenshot that includes threads and handles, if that helps



As before, us laptop users can suss it out pretty quick as the fans start going crazy
 
R

renex

Guest
Well so that's fixed now! I had an overheating issue that made me completely stop using gms2.
 

WarpDogsVG

Member
I wanted to follow up on my earlier post about poor performance. I figured out the issue.

There's an option in the Windows config called 'Use synchronization to avoid tearing'. I certainly don't remember ever ticking this option - I haven't touched those settings since I started a month back - but after a painstaking 1 hour teardown of my poor project I finally narrowed down that as the culprit

With it on, I was averaging ~45-50 room FPS and ~2000 "real" FPS (and overall 'felt' sluggish) on an older laptop ever since updating to 2.0.4.6x. After ticking it off, that jumped back to a solid 60 and ~4000, respectively

I started a fresh project and noted it's ticked off by default. I'm sure I'm to blame here - probably just a misclick or something equally silly - but it does seem coincidental that I only noticed it immediately after the update. I work on this project 8 hours a day and am overall pretty sensitive to any changes, so I think I would have noticed if I had done it before the update...

Anyway, just putting it out there. Would be curious to know if other folks see anything similar
 

Mike

nobody important
GMC Elder
I think there's still a leak somewhere. It definitely starts out fine, but after some usage (maybe an hour?) the idle CPU goes back to crazy - hovering around 45-50% with no activity. Here's a screenshot that includes threads and handles, if that helps



As before, us laptop users can suss it out pretty quick as the fans start going crazy
Whats your machine spec? can you take a picture of the about box (From the HELP menu in GMS2)? (same for anyone that still has issues please...)
 
M

matthewgrander

Guest
Whats your machine spec? can you take a picture of the about box (From the HELP menu in GMS2)? (same for anyone that still has issues please...)
Ok, I still have this problem.
Today I played more with GMS2 after the update.

I used GMS2 for about ~3 hours -> in background it takes about ~55% of processing power and when window is active ~75%.
When I turn app off and on -> processors task in background showes ~5% active window gives ~30%
But yeah, most important is that i found it taking more after some time.

These numbers are with the same project open.

(anyway after update it feels like it takes more time to consume processors power)
 

Attachments

rwkay

YoYo Games Staff
YYG Staff
@matthewgrander - can you please tell us what is appearing in your Help -> About box for the graphics driver (is it MESA) - it may be you are using the Software rasteriser, in which case you will see high CPU usage, it could also be your graphics driver taking a large hit on the CPU, in which case the answer is the same on both counts, update to the most recent graphics driver for your card.

Russell
 
M

matthewgrander

Guest
@rwkay - I posted screenshoot in previous post. I tells me about my GTS 450 and Nvidia driver version -I updated it now to the newest version and will check if there is any difference. I hope that somebody that will notice the same problem will reply to this topic too.
 

rwkay

YoYo Games Staff
YYG Staff
Can I just check to see what you have set in File -> Preferences -> General -> Power Saving (it should be set to 100, 35, 15 by default) if you have changed any of those then that would explain your power saving...

Also what happens when you minimise the app???

Russell
 
M

McWolke

Guest
i've got the same issue:


my computer:


Power Saving stuff is default
 

Mike

nobody important
GMC Elder
Do you get these values when you click away from the app - so it's not in focus, or is that what you get while using it?
 
M

McWolke

Guest
i don't know when it started, but it stayed until i closed the app. focus didn't matter
 

Mike

nobody important
GMC Elder
Can I pester you to open it up, load a project then click out of the program onto another one (say Chrome or something), then watch the task manager and see what happens. It'll take a few seconds but it "should" drop once you click away....

When in focus, it'll use your current "AC Power" setting - lowering this should also lower the CPU/Fan etc.... 30-50% is still a pretty responsive setting.
 
M

matthewgrander

Guest
Power Saving in mine is also default.
When app have about 75% usage of processor and I make it so its not in focus then it drop about to 50% as I said before in my post.
But when I open app so its fresh (with project) starts with ~38% usage and not in focus have about ~5,5% (so that looks like it should, taking into account this power saving (15% when not in focus)
 
Last edited by a moderator:

rwkay

YoYo Games Staff
YYG Staff
I am wondering if there has been some installation issue and you have not gotten the latest version installed properly (though I have to admit I am at a loss to explain why you are seeing such high usage) If you have not already tried an uninstall and reinstall can you please try that, mainly to rule it out as a possibility

Can you please send me a PM with a DxDiag from your machine?
also are you using an SSD or a hard disk???

Russell
 
M

matthewgrander

Guest
@rwkay indeed installation seems to be the problem for me!
As the patch was released (2.0.4.65) I installed it immediately and my GMS2 was showing me that I have this version and problem was still there.
But after I uninstalled program manually (as you told me) and installed from previous downloaded installation file (ver. 2.0.4.65 -which, I believe, isn't yet on yoyogames website (download lead me to 2.0.4.64)) now ~3 hours later still have the same processor usage as with fresh open project and it is not incrementing over time. I hope it is really ok now. Maybe something goes wrong with that update on my pc.

Thank you a lot as I'm currently switching to GMS2 because it feels much better to create in.

So if some of you experience this thing, you can try: uninstall current GMS2 and install game maker in version 2.0.4.65 (which will download to your pc if you will turn on lower version)
 
Last edited by a moderator:

MrCook

Member
Hi,
I'm testing out GMS2 trial (IDE 2.0.5.77 runtime 2.0.5.49). I'm getting 40% cpu usage while idling on an open project. Without an open project at launch, it's ~10%. Out of focus project ~3%. Is there anything I could do to get this lower (apart from power saving settings)?

I work on a win7 64bit laptop (Geforce GT330M DX10 GPU, 8GB RAM, intel i5 M520 CPU). I know it's an old one, but serves me well in general.

For comparison, the unreal4 editor (a beast) takes up roughly 47% cpu usage (but 3x memory) idling on an open 3d project.
 

rwkay

YoYo Games Staff
YYG Staff
We are testing a version internally that vastly improves this cpu usage, this will be made public over the next few weeks (we have a few things to do before release)

Russell
 
Top