• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!
  • Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

Question - IDE 50-55% CPU Usage doing nothing in 2.0.4.64?

S

Sin_of_Nature

Guest
Is anyone else experiencing high cpu utilization with the latest update? I'm not even running the compiler, I'm just in the IDE doing nothing. It used to be around 3-5% but now it sits at around 50%. Makes my laptop CPU fans go crazy (not to mention, murder my battery).

[update]
I've just noticed it's when a project is open. With no project is open, it sits at the previous 3-5%

Intel i5 3230M
16 GB RAM
Crucial 240GB SSD
Windows 7 Pro (64 Bit)
 
Last edited by a moderator:

Mike

nobody important
GMC Elder
Chances are your using the MESA software driver. go into the HELP menu and pick "about". What do you see there?

When you tab away from the app, CPU usage will drop to next to nothing. But your laptop GFX card might not be able to run it fully so...
 

gnysek

Member
Yeah, it's first time I hear my notebook fans, since I bought it 4 months ago... uses around 40% all the time.

For me it uses Intel HD 530, but I also have GeForce GTX 950M on board, which it could take.
 
S

Sin_of_Nature

Guest
It stays at 50% whether its the active window or not or even minimised.

No mention of MESA driver in the Help -> About. It says Intel HD 4000 as you'd expect for 3rd Gen CPU.

My issue is that until I updated today, it ran fine. Something has changed.

IDE Version: 2.0.4.64
Current Runtime: 2.0.4.62

Intel(R) HD Graphics 4000 Intel
4.0.0 - Build 9.17.10.2843
Intel64 Family 6 Model 58 Stepping 9, Genuine Intel
 

lizzard

Member
I also have high cpu when a project loaded (started with todays update). 25-40% CPU.
In About it says:
IDE: 2.0.4.64
Runtime: 2.04.42
GeForce GTX 980M/PCIe/SSE2 NVIDIA Corporation
4.5.0 NVIDIA 378.59
Intel64 Family 6 Model 94 Stepping 3, GenuineIntel

OS: Windows 10
CPU: Intel Core i7-6700K @ 4.00GHz
 
Last edited:
S

Sin_of_Nature

Guest
llizzard
OK, good to know I'm not the only one. Let see if we can find any common factors. What OS and CPU do you have?

A GTX980M should not be having any issues, surely. That's a decent GFX card (unlike my Intel toy one)

I also bought the Mobile license today if that makes any difference
 
Last edited by a moderator:

gnysek

Member
Looks like some strange bug. Right after I'm closing IDE, laptop fans stops to work and PC is again silent.
 
S

Sin_of_Nature

Guest
Yeah, it definitely the GameMakerStudio.exe causing the high CPU. What OS are you? Windows 7,8 or 10 and 32 or 64 bit?

Hmmm, just noticed lizzard has updated his details. Win 10, 6th gen CPU and a decent GFX card. Couldn't be any further away from my old work horse of a laptop.

Looks like some strange bug. Right after I'm closing IDE, laptop fans stops to work and PC is again silent.
 
Last edited by a moderator:
Same issue as well. Windows 10 64-bit, after the update as soon as I open a project the fans kick on high, processor usage spikes and won't go down.

upload_2017-1-27_9-4-39.png

upload_2017-1-27_9-19-10.png
 
Last edited:

Ariak

Member
Im also experiencing this problem.
If no project is open all is fine ~10%, with just the start screen.
Open a completely fresh project with nothing in it ~60% CPU usage.
 

Mike

nobody important
GMC Elder
*slap* stop it! :)

Its not the end of the world.... it works fine, just a little high on CPU usage. We'll look to fix it next week.
 
S

Sin_of_Nature

Guest
Well, I'm just happy you managed to locate the issue so quickly :)

Thanks for looking into it.

*slap* stop it! :)

Its not the end of the world.... it works fine, just a little high on CPU usage. We'll look to fix it next week.
 

Ludiq

Member
I can report the same when on starting page cpu usage is good but when I open a blank project cpu usage go to 99 % and stays there.I cant even draw on the sprite editor its lagging soo much. Is there any way to downgrade versions or it will be fixed soon?
 

Ludiq

Member
One more thing just made simple project with one object and simple movement code and tried running it several times and sometimes it exits the whole program without any errors or something and sometimes it doesnt even start to run it. Where is the problem?
 

WarpDogsVG

Member
I'm also noticing a fairly big performance hit to my built game as well. Investigating this problem lead me to find the thrashing CPU on Studio itself, but even if I build an executable and close studio the built game is still noticeably slower

It dropped from 60fps solid to 45-50 variable after the update. There's nothing going on in this room so definitely points to an underlying issue

Could that be related, or something separate?

e: Also seems like restarting Studio only makes it worse. Went from thrashing around 50-60%, after a few restarts (of Studio, not my PC) it's now hovering around 95% and locking my computer
 
Last edited:

rwkay

YoYo Games Staff
YYG Staff
On the runtime side of things then try setting the Sleep Margin to 10ms does it still have a big hit on the fps???

Russell
 

Mike

nobody important
GMC Elder
remember if the IDE is CPU hogging, it will effect the running game as well.
 

WarpDogsVG

Member
Unfortunately the 10ms Sleep Margin didn't do the trick. I tried both within the IDE but also as an separate executable after closing the IDE - the performance hit is the same with either method

I have two laptops and it appears to only be affecting the older one. If I knew how to 'downgrade' IDEs I could do further testing, but here's what I got:

Older Laptop
* Win10 64bit
* i5-3210M @ 2.5ghz
* 8gb RAM
* Intel HD Graphics 4000

Newer Laptop
* Win10 64bit
* i7-6700 @ 2.6ghz
* 16gb RAM
* GeForce GTX 970M

Unsurprisingly, the newer laptop always performed better - fps_real returns ~4,000 on the newer, ~2000 on the older - but fps always returned 60fps for both of them prior to the update. Now the older runs ~45-50, newer appears unphased

Actually, fps_real still returns values of ~2000 on my old laptop. It's only the "room FPS" that's impacted. In the past when I've seen that I could always clear it up with either a Clean command or via a restart. Neither works in this case

edit: Phew, sorry for the long post, but I just tried something drastic: I deleted every single object in my game save for the debug counter. The FPS counter is literally unchanged - still waffles between 45-50fps with nothing on the screen save for the room background
 
Well I'm experiencing high CPU load too (50%), but peformance seems to be better actually.
Question about this update (not worth its own topic I think): where is this new 'PNG-to-tilemap tool' ?
 
B

bkwrm

Guest
Same here, win10 64 bit. Seems to kill my chrome browser as well if I try to do anything in it while gamemaker is open (was on a youtube tutorial video), it jumps up to 20-40% cpu usuage if Gamemaker 2 is running.
 

Ednei

Member
Same here, win10 64 bit. Seems to kill my chrome browser as well if I try to do anything in it while gamemaker is open (was on a youtube tutorial video), it jumps up to 20-40% cpu usuage if Gamemaker 2 is running.
bug3.png

I'm having the same problem here.
My computer has the following configuration:

Windows 10 , laptop Samsung
Intel® Celeron® Processor 847 (2M Cache, 1.10 GHz) (2 cores) with 8 GB Ram ( MINIMUM SPEC)

With this configuration I always rode GMS 1.4 without problems.

A topic similar to this has been opened reporting problems with version 2.0.3.56:
https://forum.yoyogames.com/index.p...low-sometimes-edited-title.15869/#post-113716

As you can see in my case the CPU is being used in 92% with GM2 without performing any task.

Ednei


MOD EDIT: Your image has been removed as my antivirus software blocks it as coming from a malicious source (using Malware bytes).
 
Last edited:
B

bkwrm

Guest
Even better, we can't use the old version. I happened to have my last download still and Gamemaker 2 is forcing me to upgrade during login, which is pretty bullcrap honestly. Rest of screen is greyed out and my only options are to check release notes and download the new version.
 
Z

zendorf

Guest
Yikes, I am glad I read this thread before turning on my machine today. Made sure I turned off my wifi beforehand, and will happily skip this one. I do understand why Yoyo wants everyone on the same version, but it would be useful to be able to downgrade to a previous version when something like this happens...
 

Mike

nobody important
GMC Elder
Yup.... room editor, via the room menu.

upload_2017-1-28_10-8-12.png

I do understand why Yoyo wants everyone on the same version, but it would be useful to be able to downgrade to a previous version when something like this happens...
This will happen once it's fully released. For Beta, dem's the rules...
 

rIKmAN

Member
This will happen once it's fully released. For Beta, dem's the rules...
Did the high CPU threading issue not show up on any of the machines you tested the beta update on before pushing it out?
(You did test it, right?) :p
 

Graham1953

Member
Intel Core i7 920 2.67GHz @ 3.2 GHz
MMX SSE SSE2 SSE3
12GB System RAM
NVIDIA GeForce GTX 970
Windows 10 64bit

GM v2 no game loaded 12%, project loaded and running 30%
GM v1.4 no game loaded 2%, project loaded and running 5%

hope that's some help.
If your CPU is running at 100% you could be in danger of overheating your CPU if over clocked.
 
Last edited:

gnysek

Member
@Graham1953 They already found a bug. They probably didn't noticed, as they are testing on PC, not on notebook, where it's easier to hear high CPU because of fans going crazy, while on PC and in office, everything is loud.
 

psyke

Member
Can confirm, Windows 10 64 bit, 50%> CPU usage.
Also, something that's really bothering me is that the "reload - save" dialog box is happening all the time in the new version, sometimes I change one sprite or resource and then the popup shows, didn't happened in previous versions, only when changing included files.
 
A

Andy

Guest
Things start slowing down sometimes for me also, so I have to close and reopen GMS2 every once and awhile. My PC info:
Operating System
Windows 10 Pro 64-bit
CPU
Intel Core i5 4690 @ 3.50GHz 48 °C
Haswell 22nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 799MHz (11-11-11-28)
Motherboard
ASUSTeK COMPUTER INC. Z87-PRO (SOCKET 1150) 31 °C
Graphics
HP w2007 (1680x1050@60Hz)
3072MB ATI AMD Radeon R9 200 Series (Sapphire/PCPartner) 36 °C
Storage
931GB Western Digital WDC WD10EZEX-08M2NA0 (SATA) 28 °C
111GB Samsung SSD 850 EVO 120GB (SSD) 34 °C
Optical Drives
ASUS DRW-24B1ST a
Audio
Realtek High Definition Audio
 
Last edited by a moderator:

Cpaz

Member
I can also attest, I have ~>35% - <45% when GMS2 is idle. Good to see it's fixed!

*slap* stop it! :)

Its not the end of the world.... it works fine, just a little high on CPU usage. We'll look to fix it next week.
(I'm honestly surprised he didn't pull out the "gun" and let you off with a measly slap)
 
H

hathor

Guest
CPU hovering at ~60%. Still plenty usable for me, but I didn't notice this on the previous update.
 
Even better, we can't use the old version. I happened to have my last download still and Gamemaker 2 is forcing me to upgrade during login, which is pretty bullcrap honestly. Rest of screen is greyed out and my only options are to check release notes and download the new version.
You can if you install the old version and disconnect from the internet when running it. It's a PITA, but it works.
 
Z

Zibidibodel

Guest
Hoping this is fixed soon. I just downloaded the beta of GMS2 today to test it and decide whether to upgrade. The interface is a huge improvement, but after 5-10 minutes, my CPU usage hits 99% when doing a very simple game build, causing my computer to almost crash. Guessing I'll wait to see how it actually runs when this gets fixed.

My specs:
Windows 10 Home 64-bit
Intel i3-6100 @ 3.70GHz
Nvidia GTX 1050ti
8gb RAM

Edit: Added specs
 
M

matthewgrander

Guest
Same issue here. Started from ~50% and ended in taking ~90% processors power

edit: ended up eating all power. I need a restart for GMS2 to start with about ~70% usage of processor.
 
Last edited by a moderator:
Top