• Hello [name]! Thanks for joining the GMC. Before making any posts in the Tech Support forum, can we suggest you read the forum rules? These are simple guidelines that we ask you to follow so that you can get the best help possible for your issue.

OFFICIAL 2.3.5 Stable Release Thread

O.Stogden

Member
url_open also seems to not do anything in the Opera GX export, unsure if that's intended behaviour or not. Nothing gets returned in the browser console or the GM console when trying to run the function from what I can tell.
 

JadeMonsuta

Member
Keyboard shortcuts don't work in the room editor when editing a tile layer anymore.
It looks like editing object layers functions as normal but I'm not able to use any key inputs for editing tile layers.
Other people on my team were able to recreate the issue without fail after updating.
 

Alyxx

Member
Keyboard shortcuts don't work in the room editor when editing a tile layer anymore.
It looks like editing object layers functions as normal but I'm not able to use any key inputs for editing tile layers.
Other people on my team were able to recreate the issue without fail after updating.
Same here, this is a huge issue.
 

Chernoby

Member
I updated to IDE v2.3.5.589. I'm on a Macbook laptop.
  1. The GMS 2 interface has way bigger icons and font size now making it difficult to use.
  2. The trackpad doesnt work like it did before updating like I could pinch in and pull out my fingers to zoom in/out, now I cant.
  3. The laptop icon disappeared and reappeared only after going into Settings of Input and selecting laptop mode there. After selecting it, the icon is back where it normally is (next to "collapse/expand dock panels" icon) and I can toggle it on and off and it stays in place but it doesnt do anything, navigation acts no different at least with the track pad (have not tested with a mouse).
 

gnysek

Member
On previous page I've mentioned, that Ctrl+Tab is working for me, and I've even made a screenshot, to prove it.

Seems that it's not entirely true - it works only, if any of code editors is focused. Otherwise - it navigates forth and back trough every form elements in each window, highligthing things in white rectangles:

1633293226421.png
1633293082924.png
1633293244871.png

So it depends on what's focused.
 

Xennroth

Member
What is the overall security of the Opera GX export? I really want to submit a demo version of Decks of Dexterity to the competition before I have the game fully finished for a Steam release, but I have some degree of concern for the potential of piracy or ripping assets. Like the HTML5 export games can be downloaded and assets extracted with minimal effort.
all games build with gms have 2 pieces: a runner for specific platform, and 1 data file (.win .unx).
the problem with this setup is that the data file has full sourcecode and all assets, and it can be decompiled if you dont add 3rd-party protection yourself.

on windows builds you can protect your sources by running the game on virtual system ("themida" is a good one), but for web based platforms operagx-wasm html5 etc i dont think there is a good solution, other than hosting the game on a website yourself and restricting all access to the .unx data file (and runner.data).

it would add a LOT of security if gms packed the .exe and .win to 1 executable file instead of 2 files, or if the data file was obfuscated on build with a random key.
 
Last edited:
I had issues that caused the GMS / IDE to close as soon as it was executed. Simple Fix but still had an issue. This should not have happened.
 
The room CTRL-C/V bug present in the 2.3.6 beta is now present in the stable version, i hope will be fixed quickly.

I also see a strage thing when run an executable with debugger, the IDE move up and the top part of the GMS IDE window become not visible, only the part with file and other things is visible but the border of the window is not and so can't be moved or closed or reduced.
 

poorlocke

Member
Keyboard shortcuts for tiles in room editor don't seem to work for me. EG the "L" button enables the line tool for tiles, nothing happens when I press it. Win 10 64x, I've tried restarting and logging out.
Edit: also ctrl-x ctrl-c ctrl-v don't work. "G" for toggling the grid works normally
 
Last edited:

rwkay

YoYo Games Staff
YYG Staff
all games build with gms have 2 pieces: a runner for specific platform, and 1 data file (.win .unx).
the problem with this setup is that the data file has full sourcecode and all assets, and it can be decompiled if you dont add 3rd-party protection yourself.

on windows builds you can protect your sources by running the game on virtual system ("themida" is a good one), but for web based platforms operagx-wasm html5 etc i dont think there is a good solution, other than hosting the game on a website yourself and restricting all access to the .unx data file (and runner.data).

it would add a LOT of security if gms packed the .exe and .win to 1 executable file instead of 2 files, or if the data file was obfuscated on build with a random key.
This is incorrect as the source code is not within the WAD and cannot be fully decompiled (though some have tried) and assets are encoded (but others have put a lot of effort into breaking it all apart, which happens to any successful game / engine). If you use YYC then you can create an executable that has been natively compiled and this makes it even harder to decompile (in much the same as any game).

Packing everything into a single EXE (including all the data) is just a silly idea for anything but the smallest of games and could not be seriously considered for anything above Catch the Clown type games.

Russell
 

FrostyCat

Member
@rwkay I have filed a ticket about keyboard_string not working and doing wild-pointer-like things on the Opera GX export (#189131), but I received a reply from you that follows the template for suggestions (which says it is internally discussed), not bug reports (which would say that it has been noted on Mantis). Same for the "Emscripten linking" crash on 2.3.6 beta (#189134). Is there a change going forward in the way bug reports are handled, or did you mistakenly file these as suggestions?
 

rwkay

YoYo Games Staff
YYG Staff
@rwkay I have filed a ticket about keyboard_string not working and doing wild-pointer-like things on the Opera GX export (#189131), but I received a reply from you that follows the template for suggestions (which says it is internally discussed), not bug reports (which would say that it has been noted on Mantis). Same for the "Emscripten linking" crash on 2.3.6 beta (#189134). Is there a change going forward in the way bug reports are handled, or did you mistakenly file these as suggestions?
keyboard_string is fixed and I have fixed the Emscripten linking bug today, fix should be in the Beta tomorrow.

Not sure why they used the suggestions template, human error I think.

Russell
 

Yal

🐧 *penguin noises*
GMC Elder
Keyboard shortcuts don't work in the room editor when editing a tile layer anymore.
It looks like editing object layers functions as normal but I'm not able to use any key inputs for editing tile layers.
Other people on my team were able to recreate the issue without fail after updating.
I'm also seeing this (and it's making tile layers almost impossible to work with)
  • D / R / F / S to change editing type (Draw, Rectangle, Fill, Select) doesn't do anything, it can be worked around by clicking the buttons in the room editor and is only moderately tedious
  • Delete doesn't do anything even after you select tiles, so if you want to delete a large area you need to use the eraser (this quickly gets very tedious)
  • Copy/cut/paste (Ctrl+C etc) doesn't do anything, so it's impossible to reuse a group of tiles for quick editing unless you knew about it in advance and made a brush. I often work iteratively and move things around by cut-and-pasting them and there's no mouse-only alternative for this :<
 

gnysek

Member
I'm having strange issue, where pressing Ctrl+Z after drawing first thing ever in new sprite, closes sprite editor and goes back to workspaces (even if new frame, or resize were made before that first draw).
 

John4300

Member
I'm having strange issue, where pressing Ctrl+Z after drawing first thing ever in new sprite, closes sprite editor and goes back to workspaces (even if new frame, or resize were made before that first draw).
I have had a similar problem to this, but I haven't used Game Maker in a little while (Since 2.3.4 release). Ctrl+Z feels like it sometimes "Crashes" the sprite editor, the most annoying thing being that the change made is not undone so you are left with whatever you did. I'm not sure does this have to do if the sprite editor is not focused, but you are focusing on the main workspace.
 

Alyxx

Member
I'm also seeing this (and it's making tile layers almost impossible to work with)
  • D / R / F / S to change editing type (Draw, Rectangle, Fill, Select) doesn't do anything, it can be worked around by clicking the buttons in the room editor and is only moderately tedious
  • Delete doesn't do anything even after you select tiles, so if you want to delete a large area you need to use the eraser (this quickly gets very tedious)
  • Copy/cut/paste (Ctrl+C etc) doesn't do anything, so it's impossible to reuse a group of tiles for quick editing unless you knew about it in advance and made a brush. I often work iteratively and move things around by cut-and-pasting them and there's no mouse-only alternative for this :<
Yeah same. I've never used brushes tbh.
 

Yal

🐧 *penguin noises*
GMC Elder
Yeah same. I've never used brushes tbh.
Brushes are really useful if you arrange the tileset per type (e.g. this region is solid, this region is slopes, this region is just decorative and has no collision) and some "logical objects" are made from more than one type of tile (e.g. a grassy slope where the grass visually continues into the solid ground below), you can bring the different tiles together in a brush so you can paint the entire thing with one click.

(I'm a big fan of using tile-based collisions, using decorative-only tiles + invisible objects for collisions basically doubles your workload and it's easy to leave in a little gap in a corner somewhere without realizing)
 

Alyxx

Member
Brushes are really useful if you arrange the tileset per type (e.g. this region is solid, this region is slopes, this region is just decorative and has no collision) and some "logical objects" are made from more than one type of tile (e.g. a grassy slope where the grass visually continues into the solid ground below), you can bring the different tiles together in a brush so you can paint the entire thing with one click.

(I'm a big fan of using tile-based collisions, using decorative-only tiles + invisible objects for collisions basically doubles your workload and it's easy to leave in a little gap in a corner somewhere without realizing)
Fair enough, though I prefer the latter method even if it's more time consuming.
 

vdweller

Member
Does cut/paste work for you when you select a tileset area? It stopped working for me...

EDIT: Apparently I am blind.
 
Last edited:

blexc

Member
Keyboard shortcuts don't work in the room editor when editing a tile layer anymore.
It looks like editing object layers functions as normal but I'm not able to use any key inputs for editing tile layers.
Other people on my team were able to recreate the issue without fail after updating.
I have the same issue. I've tested this on the latest beta build (Version 23.1.1.399 Download), and tile set select, copy, paste, etc. all works fine. On stable release it just does not work.
 
Something is wrong with the Keystore tool it seems. While I've successfully GENERATE new keystore file, and no problem for it to SHOW KEY HASH (recall v.2.3.4 freeze). It seems a different story when building an apk/aab or even running (F5) with Android as its target.

I tested several times with the keystore generated using v.2.3.5 stable, on v.2.3.5 stable and v.2.3.6 beta, same result each time. This error message is received with build failed each time (no apk/aab was generated);
FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':[redacted]packageRelease'.
> A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
> com.android.ide.common.signing.KeytoolException: Failed to read key [ ALIAS] from store "D:\PROJECT FOLDER GameMaker Studio 2\Project Folder\[KEYSTORENAME].keystore": Get Key failed: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 5s
44 actionable tasks: 4 executed, 40 up-to-date
  1. Do note that [ALIAS] is my alias which I'm redacting from the above info. Same case with [KEYSTORENAME] and the package release name which I redacted from the above info.
  2. I'm using Android Studio Arctic Fox revision 2 (up to date SDK and its related files)
  3. Preference and Game Options info can be viewed in attached image below.
xxx.png

For comparison;
I did a test with the exact same project file, but this time borrowing a keystore from my older project generated using v.2.3.4 and older. Build it on v.2.3.5 stable and v.2.3.6 beta, result was Build Success. No problem making an apk/aab, or even testing (F5) on Android target. Something is not working correctly with the tool used to read/decrypt the keystore for building on both v.2.3.5 and v.2.3.6 beta.
 
Top