Windows 12/19/18 IDE broke my Doors (child of my main collision object)

Discussion in 'GameMaker Studio 2 Community Tech Support' started by Peter Starostin, Dec 20, 2018.

  1. Peter Starostin

    Peter Starostin Member

    Joined:
    Dec 20, 2018
    Posts:
    5
    Hey guys. I have a door that closes an area during some triggered event. That door is a child of my collision object (or basically my walls and floor) The door was working fine until today's update. now for some reason, player and enemies can pass through the door, unless I exit and come back in to the room. Or if I reload the room. :(

    Also their not using dynamics. I'm just doing the instance_place(x, y, obj_Enemy); thing to check for collision with the parent object.
     
  2. Peter Starostin

    Peter Starostin Member

    Joined:
    Dec 20, 2018
    Posts:
    5
    Update --- Ok I noticed some of my platforms also weren't working. But, if I stick the platforms and my door in the first room, just somewhere off screen (kind of loading them ahead of time), then they work in all the other rooms too. Strange, it works but wish I didn't have to.
     
  3. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    394
    this sounds like a GM bug though, maybe you should file it using the help > report a bug in gamemaker
     
  4. gnysek

    gnysek Member

    Joined:
    Jun 20, 2016
    Posts:
    1,246
    If it worked until update, just switch to previous runtime in settings.
     
  5. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    162
    This happened to me with the previous runtime but the latest one should hopefully fix it, which one are you using?
     
  6. Luminous Wizard

    Luminous Wizard Member

    Joined:
    Jun 21, 2016
    Posts:
    98
    I am having issues with the instance_place function in any runtime released after 2.2.0.261.
     
  7. Carnivius

    Carnivius Member

    Joined:
    Jun 20, 2016
    Posts:
    162
    yeah turns out i'm still having problems with it in 2.2.1.291. Really screwing things up with my projects. Frustrating.
     
  8. rIKmAN

    rIKmAN Member

    Joined:
    Sep 6, 2016
    Posts:
    3,517
    Check the release notes to see if there is anything listed which might have affected your existing code.

    If you can't see anything you can roll back to a previous runtime where things worked, and file a bug with your project showing the issue (or a stripped down demo project showing the issue).
    In the IDE go to Help > File a Bug and fill out the form.
     
  9. Peter Starostin

    Peter Starostin Member

    Joined:
    Dec 20, 2018
    Posts:
    5
    Hey guys.. I just stripped my project of pretty much everything and submitted a bug report. Hopefully next Runtime will fix it. In the meantime I'll have to keep those objects loaded in my 1st room.
     
  10. Peter Starostin

    Peter Starostin Member

    Joined:
    Dec 20, 2018
    Posts:
    5
    Well. I got a reply saying latest Runtime fixed the issue, when it clearly didn't. I responded last week saying as much, but haven't heard back yet.
     
  11. ph101

    ph101 Member

    Joined:
    Jun 20, 2016
    Posts:
    394
  12. Peter Starostin

    Peter Starostin Member

    Joined:
    Dec 20, 2018
    Posts:
    5
    Ah yes. I think that's it. Thanks. :D
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice